Ubuntu 7.10 erschienen!

Alles, was nicht direkt mit Python-Problemen zu tun hat. Dies ist auch der perfekte Platz für Jobangebote.
Benutzeravatar
tiax
User
Beiträge: 152
Registriert: Samstag 23. Juli 2005, 17:28
Kontaktdaten:

Beitragvon tiax » Freitag 19. Oktober 2007, 15:41

Leonidas hat geschrieben:Ich denke, die werden in den nächsten Tagen wohl ein Update verteilen müssen :)


Warum denn? Feisty hat doch auch den Zweijahres-Supportplan (Nicht-LTS) bis 2009?
Ne invoces expellere non possis
xmpp:florian@florianheinle.de
Benutzeravatar
Leonidas
Administrator
Beiträge: 16023
Registriert: Freitag 20. Juni 2003, 16:30
Kontaktdaten:

Beitragvon Leonidas » Freitag 19. Oktober 2007, 18:56

tiax hat geschrieben:
Leonidas hat geschrieben:Ich denke, die werden in den nächsten Tagen wohl ein Update verteilen müssen :)


Warum denn? Feisty hat doch auch den Zweijahres-Supportplan (Nicht-LTS) bis 2009?

Klar. Aber ich denke, dass die doch auf 7.10 updaten werden. Warum? Naja, wer lang anhaltenden Support braucht, nimmt ein LTS, wie etwa Dapper bei Pyhosting. Wer lieber halbwegs aktuelle Software nutzt, der aktualisiert etwa ale 6 Monate und kommt auch mit den nicht-LTS-Versionen klar.

Außerdem, Universitätsadmins werden sich da wohl nicht allzusehr bitten lassen, wenn sie schon ein nicht-LTS fahren auf ein aktuelleres Release zu wechseln. Ist ja schließlich nicht schwer, kann man problemlos mit einem lokalen APT-Mirror und einigen cron-Jobs erledigen. Und man spart sich die Fragen der Informatikstudenten, wann denn endlich aktualisiert wird :D

Aber wenn es dich beruhigt, kann ich ja mal nachfragen wie der Plan aussieht ;)
My god, it's full of CARs! | Leonidasvoice vs Modvoice
CM
User
Beiträge: 2464
Registriert: Sonntag 29. August 2004, 19:47
Kontaktdaten:

Beitragvon CM » Montag 22. Oktober 2007, 09:40

Ich habe vor ein paar Tagen die Upgrade-Funktion in Anspruch genommen. Mein Fazit vorab: Mehr Probleme, als sichtbare Verbesserungen.

Aber der Reihe nach ... Bei dem Upgrade oder danach habe ich folgendes erlebt:
- kryptische Meldungen zu CUPS und gcc. Scheint aber beides zu funktionieren. Gestört hat mich bei den Meldungen aber, daß ein diff zu verschiedenen Dateien angezeigt wird, bei denen zum Teil (scheinbar) gar kein wesentlicher Unterschied besteht (nur der Kommentar anders, nur unbedeutende Optionen anders, etc.), die aber vielleicht doch bedeutend sind. Und das alles ohne Erklärung.
- der Upgrade dauerte wesentlich länger als angegeben
- beim Upgrade wurden - ohne mich zu fragen - verschiedene Pythonmodule entfernt und anschließend nicht wieder automatisch installiert. Inwieweit das mit einem Systemupdate zu rechtfertigen ist, bei dem die Pythonversion unangetastet blieb, ist mir nicht eingängig.
- Mit Evolution (dem Mailclient) habe ich nur noch Probleme, de facto funktioniert er nicht mehr. (input / output errors, Account durcheinander)
- Meinen ATI OpenGL-Treiber hat Ubuntu wieder runtergeworfen. Neuinstallation funktioniert nicht mehr vollständig: Die Synchronisation klappt nicht mehr richtig. (Was daran liegt, daß ich den X server nicht neu starten kann, denn dabei hängt Ubuntu.)

Alles in Allem: Zu viele Kinderkrankheiten. Immer noch. Zwar finde ich gut, daß Ubuntu nicht so langsam updates integriert wie Debian, aber etwas mehr Augenmerk auf Stabilität wäre nicht schlecht. Jetzt werde ich wohl Zeit in eine völlige Neu-Installation stecken müssen. Juchuuu!

Gruß,
Christian
CM
User
Beiträge: 2464
Registriert: Sonntag 29. August 2004, 19:47
Kontaktdaten:

Beitragvon CM » Montag 22. Oktober 2007, 14:50

Nachtrag: Heute noch komplett neu installiert - mit all dem zusätzlichen Hin- und Her - und jetzt funktioniert es. Allerdings hat mich das "neue" Gnome auch noch nicht überzeugt ...
Benutzeravatar
C4S3
User
Beiträge: 292
Registriert: Donnerstag 21. September 2006, 10:07
Wohnort: Oberösterreich

Beitragvon C4S3 » Dienstag 23. Oktober 2007, 12:24

Als XFCE Liebhaber, habe ich heute die 7.10 Xubunutu gezogen und installiert.
Erfahrungen speziell auf meinem etwas älteren und mit problematischer Hardware bestücktem Acer-Notebook:

- Der Network-Manager, der in 7.04 noch funktioniert hat, um Profile abzuspeichern, funktioniert jetzt wieder nicht. Daher: jedes mal beim Standortwechsel muss ich per Hand umstellen (Wlan, Ethernet,...). Etwas ärgerlich.

- beim Booten zeigt das gute Stück gar nichts an. Schwarzer Bildschirm und plötzlich kommt der Login. Mir persönlich wäre eine detailierte Ausgabe lieber. Oder zumindest ein Bootsplash. Schwarz ist ganz schlecht. Aber das liegt wohl auch wieder an meinem Gerät.

- Das System bootet ein klein wenig schneller als Feisty, aber immer noch lahm im Vergleich zu Mandriva, PC-LinuxOS oder DesktopBSD

- Wie es aussieht, bin ich mein Touchpad-Problem endlich los! Das freut mich am Meisten. Die letzten Distributionen, die ich ausprobiert hatte, hatten allesamt das Problem, dass das Touchpad immer wieder eingefroren ist. Ich kann das Phänomen schlecht beschreiben. Im Ubuntu-Forum gibt es mehrere Threads von anderen Leuten mit ähnlichen Problemen. Die Maus friert für 2-3 Sekunden ein, geht plötzlich wieder. Dann erscheint der Cursor plötzlich irgendwo und löst teilweise unkontrolliert Klicks aus. Dies scheint geändert zu sein. Grund war bisher offenbar, dass die Abfrage des Batteriestatus mit dem Touchpad kollidiert ist. Wie das gehen kann, weiß ich absolut nicht. o_0

- Beim Arbeiten selbst kommt es mir ein klein wenig schneller vor. Auch der Installer war nicht mehr so träge aus dem Live-Betrieb heraus (besonders beim Partitionieren).

Summa summarum bin ich bis jetzt recht zufrieden. Mal sehen, was sich in den nächsten Tagen für Problem auftun, von denen ich noch nichts ahne.
Gruß!
CM
User
Beiträge: 2464
Registriert: Sonntag 29. August 2004, 19:47
Kontaktdaten:

Beitragvon CM » Dienstag 23. Oktober 2007, 12:29

Noch ein Nachtrag: Hatte sogar Probleme C(++)-Standardlibraries wieder einzubinden. Meine ersten Versuche irgendwas zu kompilieren sind völlig fehlgeschlagen.

C4S3 hat geschrieben:Mal sehen, was sich in den nächsten Tagen für Problem auftun, von denen ich noch nichts ahne.
Genau, warten wir also ab. Aber mein Geduldspegel ist schon etwas gefallen ...
BlackJack

Beitragvon BlackJack » Dienstag 23. Oktober 2007, 13:41

C4S3 hat geschrieben:- beim Booten zeigt das gute Stück gar nichts an. Schwarzer Bildschirm und plötzlich kommt der Login. Mir persönlich wäre eine detailierte Ausgabe lieber. Oder zumindest ein Bootsplash. Schwarz ist ganz schlecht. Aber das liegt wohl auch wieder an meinem Gerät.


Kann es sein, dass Du dem Kernel mit `vga=` einen Grafikmodus für die Konsole mitgibst? Das geht bei 7.10 nicht mehr (so einfach), weil die Framebuffertreiber nicht mehr standardmässig geladen werden. Die haben wohl zu viel Ärger mit neuen Grafikkarten und den ganzen "Schlafmodi" gemacht.

Bei ubuntuusers.de sollte es Informationen dazu geben. Weiss gerade nicht ob's im Forum oder im Wiki steht.
Benutzeravatar
BlackVivi
User
Beiträge: 762
Registriert: Samstag 9. Dezember 2006, 14:29
Kontaktdaten:

Beitragvon BlackVivi » Dienstag 23. Oktober 2007, 13:50

BlackJack hat geschrieben:
C4S3 hat geschrieben:- beim Booten zeigt das gute Stück gar nichts an. Schwarzer Bildschirm und plötzlich kommt der Login. Mir persönlich wäre eine detailierte Ausgabe lieber. Oder zumindest ein Bootsplash. Schwarz ist ganz schlecht. Aber das liegt wohl auch wieder an meinem Gerät.


Kann es sein, dass Du dem Kernel mit `vga=` einen Grafikmodus für die Konsole mitgibst? Das geht bei 7.10 nicht mehr (so einfach), weil die Framebuffertreiber nicht mehr standardmässig geladen werden. Die haben wohl zu viel Ärger mit neuen Grafikkarten und den ganzen "Schlafmodi" gemacht.

Bei ubuntuusers.de sollte es Informationen dazu geben. Weiss gerade nicht ob's im Forum oder im Wiki steht.
GENAU das find ich unter Ubuntu nicht so toll. Standardmässige normale Sachen deaktivieren, ohne eine Auswahlmöglichkeit bei der Installation. Man nimmt diese Entscheidung dem User ab, weil sie ja viel zu kompliziert wäre. Man könnte doch dazuschreiben: "Wenn sie keine Ahnung haben, was das bedeutet, lassen sie's so wie es ist."... Boah, sowas regt mich auf.
BlackJack

Beitragvon BlackJack » Dienstag 23. Oktober 2007, 13:57

Die Framebuffer-Treiber werden wohl nicht mehr so gewartet und gepflegt wie sie sollten, dann ist es IMHO völlig okay sie wegzulassen, anstatt Neueinstiegern den Eindruck zu vermitteln Linux würde dauernd abstürzen oder einfrieren. Standard ist diese Einstellung unter Ubuntu sowieso nie gewesen, man musste schon immer die `vga`-Option selber von Hand in die Konfigurationsdatei schreiben. Und wer das macht, kann bei Bedarf auch die Treiber beim Start wieder laden lassen. Wo ist das Problem!?
Benutzeravatar
Rebecca
User
Beiträge: 1662
Registriert: Freitag 3. Februar 2006, 12:28
Wohnort: DN, Heimat: HB
Kontaktdaten:

Beitragvon Rebecca » Dienstag 23. Oktober 2007, 14:00

Ist bei der Standard-Debian-Installation auch nicht aktiviert.
Offizielles Python-Tutorial (Deutsche Version)

Urheberrecht, Datenschutz, Informationsfreiheit: Piratenpartei
Benutzeravatar
BlackVivi
User
Beiträge: 762
Registriert: Samstag 9. Dezember 2006, 14:29
Kontaktdaten:

Beitragvon BlackVivi » Dienstag 23. Oktober 2007, 14:03

BlackJack hat geschrieben:Die Framebuffer-Treiber werden wohl nicht mehr so gewartet und gepflegt wie sie sollten, dann ist es IMHO völlig okay sie wegzulassen, anstatt Neueinstiegern den Eindruck zu vermitteln Linux würde dauernd abstürzen oder einfrieren. Standard ist diese Einstellung unter Ubuntu sowieso nie gewesen, man musste schon immer die `vga`-Option selber von Hand in die Konfigurationsdatei schreiben. Und wer das macht, kann bei Bedarf auch die Treiber beim Start wieder laden lassen. Wo ist das Problem!?
Leuten, die wissen was sie tun, die Möglichkeit bei der Installation zu geben, den Treiber drinne zu lassen... Finde ich sehr wichtig. Es rauszunehmen ohne das man's richtig merkt, weil ich es auch nicht wusste und ich wär gegen die Wand gelaufen, finde ich falsch. Dann soll man eben'ne Experten und 'ne Standardinstallation machen und in der Experteninstallation ist das eben sofort ersichtlich. Aber den User für zu dumm zu halten, so eine Entscheidung zu treffen, finde ich grundsätzlich falsch.

Es ist ja nicht nur das, es ist viel mehr bei Ubuntu. Viel mehr Einstellungen und Konfigurationen, Diense und sowas die alle irgendwie stören. Zwar gibts diese Server CD, aber dann kann ich auch eine andere Distribution nehmen. Ich war eigentlich immer ein großer Ubuntufan, also ich kämpfe für Ubuntu, aber das finde ich schlichtweg falsch.

Rebecca hat geschrieben:Ist bei der Standard-Debian-Installation auch nicht aktiviert.
Bei 3.1 aber, oder? Ich kann mich daran ganz schwach errinern.

//Edit: http://wiki.debianforum.de/FramebufferE ... ebuffer%29
Hier steht aber, das'r noch integriert ist. Naja, vielleicht irr ich mich wieder, ich hab Debian das letzte mal vor einer Ewigkeit installiert.
rayo
User
Beiträge: 773
Registriert: Mittwoch 5. November 2003, 18:06
Wohnort: Schweiz
Kontaktdaten:

Beitragvon rayo » Dienstag 23. Oktober 2007, 14:10

Also wenn du ja die Einfach-Installations-CD (Live-CD) nimmst, kannst du nicht erwarten eine Experten-Installation vorzufinden.

Ich hab mir Ubuntu wie immer mit dem Netinstall (9MB CD Image) im Experten-Modus installiert, da musste ich auch noch zusätzlich beim booten der CD ein vga=771 anhängen weil mein Laptop Probleme macht bei der Anzeige.

Ubuntu ist mit der LiveCD halt einfach zu installieren, darum ist es ja auch so beliebt, da man nicht alles kennen muss (und Entscheidungen dem User abnehmen). Wieviele User wollen nun wirklich wissen ob der Framebuffer Treiber läuft oder nicht, das System soll einfach laufen.
Benutzeravatar
BlackVivi
User
Beiträge: 762
Registriert: Samstag 9. Dezember 2006, 14:29
Kontaktdaten:

Beitragvon BlackVivi » Dienstag 23. Oktober 2007, 14:21

Auch bei dieser "Einfach-Installations-CD" sollte es einen Expertenmodus geben, wenn ich ehrlich bin. Aber ich bin ja kein Ubuntuentwickler, ich hab keine Ahnung... Netinstall ist ja nun was völlig anderes...
CM
User
Beiträge: 2464
Registriert: Sonntag 29. August 2004, 19:47
Kontaktdaten:

Beitragvon CM » Dienstag 23. Oktober 2007, 14:35

Na, die Installation hat bei mir ja sogar geklappt. Und Ubuntu hat mir sogar gesagt, daß es für meine Graphikkarte einen Third-Party-Treiber gibt. Der ließ sich sogar anstandslos installieren. Wow. Das war bisher immer problematisch (spätestens bei der Synchronisation). Schön, ...
Aber das Ubuntu bei einem Upgrade (vor der Neuinstallation habe ich ein Online-Upgrade versucht), bei dem Python (und andere Dinge) ganz und gar unverändert blieben, einfach Pythonmodule entfernt hat (und C/C++-Libraries) finde ich gar nicht witzig. :evil: Dazu kommen halt noch andere Dinge (s. o.).
Insgesamt teile ich die Meinung von BlackVivi und C4S3 zumindest teilweise: Als Nutzer will ich gefragt werden und als OS-Laie mit erhöhten Ansprüchen hätte ich gerne etwas (!) mehr Info. Die Ubuntu-Leute arbeiten daran - das merkt man über die Versionen hinweg auch - aber noch ist dieses Ideal nicht erreicht und das ist schon ärgerlich.
Mephisto
User
Beiträge: 28
Registriert: Mittwoch 17. Januar 2007, 15:52

Beitragvon Mephisto » Dienstag 23. Oktober 2007, 15:14

Naja, Ubuntu is halt auf einfach getrimmt, wer gerne maximale Kontrolle hat sollte zu gentoo greifen :)

greets meph

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder