Win XP SP2 pygtk - No Modul named pygtk

Programmierung für GNOME und GTK+, GUI-Erstellung mit Glade.
Antworten
Beetle
User
Beiträge: 5
Registriert: Sonntag 5. August 2007, 20:45

Sonntag 5. August 2007, 21:01

Hallo!

Ich muss mich grade mal selber outen, aber irgendwie habe ich ein Brett vor dem Kopf! :roll:

Ich habe nur ein ganz kleinen Test zum Laufen bringen wollen und bekomme immer diese Meldung: ImportError: no modul names pygtk

Wo muss ich den Pfad setzen und welches Verzeichnis wird gesucht?

Ich benutzen Python 2.5 und das Verzeichnis in dem die pygtk.h sitzt ist:
C:\Programme\Python25\include\pygtk-2.0\pygtk

ich habe es in den systemvariablen auch dem Path hinzugefügt doch leider erfolglos. Wer kann weiterhelfen?

Danke im Voraus
Beetle
Benutzeravatar
gerold
Python-Forum Veteran
Beiträge: 5555
Registriert: Samstag 28. Februar 2004, 22:04
Wohnort: Oberhofen im Inntal (Tirol)
Kontaktdaten:

Sonntag 5. August 2007, 21:56

Beetle hat geschrieben:ImportError: no modul names pygtk
Hallo Beetle!

Willkommen im Python-Forum!

Installiere in dieser Reihenfolge:

- Python 2.5 (hast du wahrscheinlich schon :-) )
- Gtk+/Win32 Development Environment --> http://gladewin32.sourceforge.net/
- PyCairo --> http://ftp.gnome.org/pub/GNOME/binaries ... cairo/1.2/
- PyGObject --> http://ftp.gnome.org/pub/GNOME/binaries ... ject/2.12/
- PyGTK --> http://ftp.gnome.org/pub/GNOME/binaries ... ygtk/2.10/

Siehe auch: http://faq.pygtk.org/index.py?req=show& ... 21.001.htp

mfg
Gerold
:-)
http://halvar.at | Kleiner Bascom AVR Kurs
Wissen hat eine wunderbare Eigenschaft: Es verdoppelt sich, wenn man es teilt.
Beetle
User
Beiträge: 5
Registriert: Sonntag 5. August 2007, 20:45

Montag 6. August 2007, 11:15

Hallo Gerold,
danke für die Hinweise. Ich habe es nach deiner Empfehlung alles deinstalliert und in der von dir genannten Reihenfolge wieder installiert.

Doch leider komme ich damit auch nicht weiter. Denn Stani's Python Editior läßt sich nun nicht mehr starten und das kleine Demoprogramm endet mit der Fehlermeldung:

Die Anwendung konnte nicht gestartet, weil libglib-2.0-0.dll nicht gefunden wurde. Eine Neuistallation könnte weiterhelfen.

Welches Modul bringt denn nun den Fehler?

Im Voraus vielen Dank für die Antwort.

Gruß
Udo
lunar

Montag 6. August 2007, 12:25

Beetle hat geschrieben:Doch leider komme ich damit auch nicht weiter. Denn Stani's Python Editior läßt sich nun nicht mehr starten und das kleine Demoprogramm endet mit der Fehlermeldung:

Die Anwendung konnte nicht gestartet, weil libglib-2.0-0.dll nicht gefunden wurde. Eine Neuistallation könnte weiterhelfen.
Hast du mal überprüft, ob das Verzeichnis, welches diese DLL (allgemein alle gtk und glib DLLs) enthält, in der PATH Variable enthalten ist?

Ein ähnliches Problem trat bei meiner Tests mit Qt4 auf, und da hat das Hinzufügen des DLL-Verzeichnisses zum Pfad mit anschließender Neuanmeldung das Problem gelöst. Ein Versuch wäre es ja wert...
Antworten