pygame wird nicht erkannt

Probleme bei der Installation?
Antworten
Breek
User
Beiträge: 2
Registriert: Samstag 7. Januar 2023, 23:02

Hallo
ich wollte mal Pygame ausprobieren und habe es dementsprechend mit dem pip command interlaiert, das hat auch geklappt. Aber dan fangen auch schon die probleme an, wenn ich

Code: Alles auswählen

import pygame
Probiere funktionirt es nicht und es sagt mir das kein Modul mit dem namen Pygame gefunden worden ist. Also lösche ich Python und Probiere es noch mal, dan heist es wieder das das nicht da ist. also Reinstaliere ich Pygame über pip, dan kommt immer das :

Code: Alles auswählen

Defaulting to user installation because normal site-packages is not writeable
Collecting pygame
  Using cached pygame-2.1.2.tar.gz (10.1 MB)
  Preparing metadata (setup.py) ... error
  error: subprocess-exited-with-error

  × python setup.py egg_info did not run successfully.
  │ exit code: 1
  ╰─> [77 lines of output]


      WARNING, No "Setup" File Exists, Running "buildconfig/config.py"
      Using WINDOWS configuration...

      Traceback (most recent call last):
        File "<string>", line 2, in <module>
        File "<pip-setuptools-caller>", line 34, in <module>
        File "C:\Users\Henning\AppData\Local\Temp\pip-install-ewrnia9s\pygame_039e068cfc2d4885b00cc3b6ebe3218d\setup.py", line 359, in <module>
          buildconfig.config.main(AUTO_CONFIG)
        File "C:\Users\Henning\AppData\Local\Temp\pip-install-ewrnia9s\pygame_039e068cfc2d4885b00cc3b6ebe3218d\buildconfig\config.py", line 225, in main
          deps = CFG.main(**kwds)
                 ^^^^^^^^^^^^^^^^
        File "C:\Users\Henning\AppData\Local\Temp\pip-install-ewrnia9s\pygame_039e068cfc2d4885b00cc3b6ebe3218d\buildconfig\config_win.py", line 511, in main
          return setup_prebuilt_sdl2(prebuilt_dir)
                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
        File "C:\Users\Henning\AppData\Local\Temp\pip-install-ewrnia9s\pygame_039e068cfc2d4885b00cc3b6ebe3218d\buildconfig\config_win.py", line 471, in setup_prebuilt_sdl2
          DEPS.configure()
        File "C:\Users\Henning\AppData\Local\Temp\pip-install-ewrnia9s\pygame_039e068cfc2d4885b00cc3b6ebe3218d\buildconfig\config_win.py", line 336, in configure
          from . import vstools
        File "C:\Users\Henning\AppData\Local\Temp\pip-install-ewrnia9s\pygame_039e068cfc2d4885b00cc3b6ebe3218d\buildconfig\vstools.py", line 11, in <module>
          compiler.initialize()
        File "C:\Program Files\Python311\Lib\site-packages\setuptools\_distutils\msvc9compiler.py", line 403, in initialize
          vc_env = query_vcvarsall(VERSION, plat_spec)
                   ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
        File "C:\Program Files\Python311\Lib\site-packages\setuptools\_distutils\msvc9compiler.py", line 281, in query_vcvarsall
          raise DistutilsPlatformError("Unable to find vcvarsall.bat")
      distutils.errors.DistutilsPlatformError: Unable to find vcvarsall.bat
      Making dir :prebuilt_downloads:
      Downloading... https://www.libsdl.org/release/SDL2-devel-2.0.18-VC.zip ed561079ec622b0bab5a9e02976f5d540b0622da
      Unzipping :prebuilt_downloads\SDL2-devel-2.0.18-VC.zip:
      Downloading... https://www.libsdl.org/projects/SDL_image/release/SDL2_image-devel-2.0.5-VC.zip 137f86474691f4e12e76e07d58d5920c8d844d5b
      Unzipping :prebuilt_downloads\SDL2_image-devel-2.0.5-VC.zip:
      Downloading... https://www.libsdl.org/projects/SDL_ttf/release/SDL2_ttf-devel-2.0.15-VC.zip 1436df41ebc47ac36e02ec9bda5699e80ff9bd27
      Unzipping :prebuilt_downloads\SDL2_ttf-devel-2.0.15-VC.zip:
      Downloading... https://www.libsdl.org/projects/SDL_mixer/release/SDL2_mixer-devel-2.0.4-VC.zip 9097148f4529cf19f805ccd007618dec280f0ecc
      Unzipping :prebuilt_downloads\SDL2_mixer-devel-2.0.4-VC.zip:
      Downloading... https://www.pygame.org/ftp/jpegsr9d.zip ed10aa2b5a0fcfe74f8a6f7611aeb346b06a1f99
      Unzipping :prebuilt_downloads\jpegsr9d.zip:
      Downloading... https://pygame.org/ftp/prebuilt-x64-pygame-1.9.2-20150922.zip 3a5af3427b3aa13a0aaf5c4cb08daaed341613ed
      Unzipping :prebuilt_downloads\prebuilt-x64-pygame-1.9.2-20150922.zip:
      copying into .\prebuilt-x64
      Path for SDL: prebuilt-x64\SDL2-2.0.18
      ...Library directory for SDL: prebuilt-x64/SDL2-2.0.18/lib/x64
      ...Include directory for SDL: prebuilt-x64/SDL2-2.0.18/include
      Path for FONT: prebuilt-x64\SDL2_ttf-2.0.15
      ...Library directory for FONT: prebuilt-x64/SDL2_ttf-2.0.15/lib/x64
      ...Include directory for FONT: prebuilt-x64/SDL2_ttf-2.0.15/include
      Path for IMAGE: prebuilt-x64\SDL2_image-2.0.5
      ...Library directory for IMAGE: prebuilt-x64/SDL2_image-2.0.5/lib/x64
      ...Include directory for IMAGE: prebuilt-x64/SDL2_image-2.0.5/include
      Path for MIXER: prebuilt-x64\SDL2_mixer-2.0.4
      ...Library directory for MIXER: prebuilt-x64/SDL2_mixer-2.0.4/lib/x64
      ...Include directory for MIXER: prebuilt-x64/SDL2_mixer-2.0.4/include
      Path for PORTMIDI: prebuilt-x64
      ...Library directory for PORTMIDI: prebuilt-x64/lib
      ...Include directory for PORTMIDI: prebuilt-x64/include
      DLL for SDL2: prebuilt-x64/SDL2-2.0.18/lib/x64/SDL2.dll
      DLL for SDL2_ttf: prebuilt-x64/SDL2_ttf-2.0.15/lib/x64/SDL2_ttf.dll
      DLL for SDL2_image: prebuilt-x64/SDL2_image-2.0.5/lib/x64/SDL2_image.dll
      DLL for SDL2_mixer: prebuilt-x64/SDL2_mixer-2.0.4/lib/x64/SDL2_mixer.dll
      DLL for portmidi: prebuilt-x64/lib/portmidi.dll
      Path for FREETYPE not found.
      ...Found include dir but no library dir in prebuilt-x64.
      Path for PNG not found.
      ...Found include dir but no library dir in prebuilt-x64.
      Path for JPEG not found.
      ...Found include dir but no library dir in prebuilt-x64.
      DLL for freetype: prebuilt-x64/SDL2_ttf-2.0.15/lib/x64/libfreetype-6.dll

      ---
      For help with compilation see:
          https://www.pygame.org/wiki/CompileWindows
      To contribute to pygame development see:
          https://www.pygame.org/contribute.html
      ---

      [end of output]

  note: This error originates from a subprocess, and is likely not a problem with pip.
error: metadata-generation-failed

× Encountered error while generating package metadata.
╰─> See above for output.

note: This is an issue with the package mentioned above, not pip.
Was kann ich tuhen das es klappt?
__deets__
User
Beiträge: 13176
Registriert: Mittwoch 14. Oktober 2015, 14:29

Welche Python Version benutzt du? Wenn die sehr neu ist (3.10 oder 3.11, weiß jetzt aus dem Kopf nicht was die neuste ist), dann kann es sein, dass solche Pakete dafür noch nicht bereitstehen. Dann einfach auf die etwas abgenhangenere Vorgängerversion wechseln.
Benutzeravatar
sparrow
User
Beiträge: 3713
Registriert: Freitag 17. April 2009, 10:28

@Breek: __deets__ hat Recht. Du verwendest laut Pfad Python 3.11. Laut PyPI steht pygame nur bis Version Python 3.10 zur Verfügung.

Für Python 3.11 müsstest du Dinge selbst übersetzen. Bleib bei 3.10, da hast du das Problem nicht. Das pygame Team wird irgendwann dann eine Version für 3.11 veröffentlichen.
Breek
User
Beiträge: 2
Registriert: Samstag 7. Januar 2023, 23:02

Ah ok danke, ich gehe dan zurück zu python 3.10
Benutzeravatar
bwbg
User
Beiträge: 400
Registriert: Mittwoch 23. Januar 2008, 13:35

Um pygame mit Python 3.11 zu nutzen, musst du die Version 2.1.3.dev8 installieren bzw. als Projektabhängigkeit setzen.
Manuell wird diese Version derzeit mit

Code: Alles auswählen

pip install pygame --pre
in deiner aktuellen (virtuellen) Umgebung installiert.
"Du bist der Messias! Und ich muss es wissen, denn ich bin schon einigen gefolgt!"
Antworten