Beim Raspberry pi 3 funktioinert der Code, beim Raspberry Pi Zero W nicht

Django, Flask, Bottle, WSGI, CGI…
erdmulch
User
Beiträge: 182
Registriert: Samstag 17. Juli 2010, 19:50

Beim Raspberry pi 3 funktioinert der Code, beim Raspberry Pi Zero W nicht

Beitragvon erdmulch » Montag 1. Januar 2018, 22:15

Hallo zusammen,

ich habe einen Raspberry pi 3 und einen Raspberry pi Zero W
auf dem Raspberry pi 3 läuft mein Code ohne Probleme.
beim Raspberry Pi Zero W bekomme ich folgende Fehlermeldung:

hat jemand eine Idee?


Unhandled exception in thread started by <function check_errors.<locals>.wrapper at 0xb5bfa588>
Traceback (most recent call last):
File "/home/pi/venv/lib/python3.5/site-packages/django/utils/autoreload.py", line 225, in wrapper
fn(*args, **kwargs)
File "/home/pi/venv/lib/python3.5/site-packages/django/core/management/commands/runserver.py", line 112, in inner_run
autoreload.raise_last_exception()
File "/home/pi/venv/lib/python3.5/site-packages/django/utils/autoreload.py", line 248, in raise_last_exception
raise _exception[1]
File "/home/pi/venv/lib/python3.5/site-packages/django/core/management/__init__.py", line 327, in execute
autoreload.check_errors(django.setup)()
File "/home/pi/venv/lib/python3.5/site-packages/django/utils/autoreload.py", line 225, in wrapper
fn(*args, **kwargs)
File "/home/pi/venv/lib/python3.5/site-packages/django/__init__.py", line 24, in setup
apps.populate(settings.INSTALLED_APPS)
File "/home/pi/venv/lib/python3.5/site-packages/django/apps/registry.py", line 112, in populate
app_config.import_models()
File "/home/pi/venv/lib/python3.5/site-packages/django/apps/config.py", line 198, in import_models
self.models_module = import_module(models_module_name)
File "/usr/lib/python3.5/importlib/__init__.py", line 126, in import_module
return _bootstrap._gcd_import(name[level:], package, level)
File "<frozen importlib._bootstrap>", line 986, in _gcd_import
File "<frozen importlib._bootstrap>", line 969, in _find_and_load
File "<frozen importlib._bootstrap>", line 958, in _find_and_load_unlocked
File "<frozen importlib._bootstrap>", line 673, in _load_unlocked
File "<frozen importlib._bootstrap_external>", line 673, in exec_module
File "<frozen importlib._bootstrap>", line 222, in _call_with_frames_removed
File "/home/pi/Waage/datefinder/models.py", line 12, in <module>
class PossibleDate(models.Model):
File "/home/pi/Waage/datefinder/models.py", line 13, in PossibleDate
poll = models.ForeignKey(Poll, related_name='possible_dates')
TypeError: __init__() missing 1 required positional argument: 'on_delete'
Benutzeravatar
__deets__
User
Beiträge: 2141
Registriert: Mittwoch 14. Oktober 2015, 14:29

Re: Beim Raspberry pi 3 funktioinert der Code, beim Raspberry Pi Zero W nicht

Beitragvon __deets__ » Montag 1. Januar 2018, 22:19

Verschiedene Versionsständevon django.
erdmulch
User
Beiträge: 182
Registriert: Samstag 17. Juli 2010, 19:50

Re: Beim Raspberry pi 3 funktioinert der Code, beim Raspberry Pi Zero W nicht

Beitragvon erdmulch » Montag 1. Januar 2018, 22:26

Ist das eine Vermutung, oder bist du dir da sicher?
in welcher Zeile der Fehlermeldung ist dies zu erkennen?
Benutzeravatar
noisefloor
User
Beiträge: 2226
Registriert: Mittwoch 17. Oktober 2007, 21:40
Wohnort: Görgeshausen
Kontaktdaten:

Re: Beim Raspberry pi 3 funktioinert der Code, beim Raspberry Pi Zero W nicht

Beitragvon noisefloor » Montag 1. Januar 2018, 22:35

Hallo,

@erdmulch: was ja aus Sicht der Supportwilligen auch total cool wäre ist:

* den Code an sich zu zeigen
* explizit zu erwähnen, dass du Django nutzt
* zu sagen, welche Django-Version du auf dem Raspi 3 verwendest

Ansonsten gibt es null Grund, warum was auf Django aufsetzendes auf dem Raspi 3 läuft, aus dem Raspi Zero aber nicht. Die Hardware ist ja egal.

Außerdem ist lt. Fehlermeldung die `autoreload` Funktion von Django der Auslöser der Exception ist - was die Vermutung nahe legt, dass du was geändert hast und dann der Code nicht mehr funktioniert.

Gruß, noisefloor
Benutzeravatar
__deets__
User
Beiträge: 2141
Registriert: Mittwoch 14. Oktober 2015, 14:29

Re: Beim Raspberry pi 3 funktioinert der Code, beim Raspberry Pi Zero W nicht

Beitragvon __deets__ » Montag 1. Januar 2018, 23:32

erdmulch hat geschrieben:Ist das eine Vermutung, oder bist du dir da sicher?
in welcher Zeile der Fehlermeldung ist dies zu erkennen?


Du hast nach Ideen gefragt. Das ist eine. Abgeleitet daraus, das sich die Parameter einer Signatur geändert haben. Das passiert üblicherweise nicht von alleine, sondern wenn man ein Paket in seiner Version ändert. Und insbesondere wenn du dann von zwei Plattformen redest, wird das eine Vermutung der man nachgehen sollte.

@noisefloor ich benutze kein Django, aber ForeignKey kommt aus dessen ORM, das erkenne auch ich. Daran sollte der Anwender eigentlich nicht Schrauben können. Und warum auto reload nur im Fehler nach Änderung vorkommen sollte, nicht aber schon beim Start, erschließt sich mir nicht. Das überwacht die Ausführung doch in beiden Fällen.
Benutzeravatar
kbr
User
Beiträge: 774
Registriert: Mittwoch 15. Oktober 2008, 09:27
Wohnort: Düsseldorf

Re: Beim Raspberry pi 3 funktioinert der Code, beim Raspberry Pi Zero W nicht

Beitragvon kbr » Dienstag 2. Januar 2018, 08:24

@erdmulch: Du hast wahrscheinlich auf beiden Raspis 'pip install django' ohne Versionsangabe verwendet und die Installation zu unterschiedlichen Zeitpunkten vorgenommen. Vor kurzem aber gab es das Release 2.0. Seitdem ist die Angabe von "on_delete" zwingend.

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder