kivent cymunk Python 3.6

Hier werden alle anderen GUI-Toolkits sowie Spezial-Toolkits wie Spiele-Engines behandelt.
Antworten
peacemaker
User
Beiträge: 16
Registriert: Sonntag 2. Oktober 2016, 14:33

Donnerstag 30. März 2017, 00:52

Hallo liebes Python-Forum,
ich habe vor ein Android Game mittels Python Kivy zu schreiben. Daher habe ich mir Kivent zusätzlich installiert und wollte die weiteren Module:
- Core
- Cymunk
- Particles
- Maps
und Projectiles hinzufügen.
Allerdings bin bei dem Versuch auf diverse Probleme gestoßen. Core konnte ich installieren, Cymunk funktioniert noch nicht. Ich bekomme derzeit die Meldung, dass alloca.h nicht gefunden wird. Also habe ich diese manuell hinzugefügt und über 100 Fehler beim kompilieren bekommen.

Ich habe mich an die Liste der Dependencies und an die Dokumentation soweit dies mir bewusst ist gehalten, allerdings habe ich im Nachhinein eine Vermutung, wegen der ich diesen Post nun schreibe.

Ich arbeite mit Python 3.6, allerdings ist der Guide auf 3.5 ausgelegt. Nun würde ich gerne wissen, ob jemand ebenfalls Kivent + Module installiert hat, und wenn ja, ob dies auch unter 3.6 problemlos möglich war.

PS: Ich werde es kommende Woche in einer Virtual Env erneut mit Python 3.5 versuchen, falls es wirklich an der Version liegen sollte.

Mit freundlichen Grüßen
peacemaker
[Windows 10]
peacemaker
User
Beiträge: 16
Registriert: Sonntag 2. Oktober 2016, 14:33

Mittwoch 5. April 2017, 12:47

Läuft einwandfrei unter 3.5

Die Installationsfehler, die ich unter 3.6 hatte, konnte ich leider nicht beheben.

mfG
peacemaker
Antworten