Development version of SDL für pygame

Hier werden alle anderen GUI-Toolkits sowie Spezial-Toolkits wie Spiele-Engines behandelt.
Antworten
Benutzeravatar
Goswin
User
Beiträge: 361
Registriert: Freitag 8. Dezember 2006, 11:47
Wohnort: Ulm-Böfingen

Sonntag 5. März 2017, 00:29

Ich benutze Linux Mint 13 Maya, und habe versucht, pygame mit
"pip install pygame" zu installieren. Das ist fehlgeschlagen mit den Meldungen:

sdl-config: not found.
Please make sure a development version of SDL is installed.

Das von mir benutzte Installierungs-Tutorial (https://pythonprogramming.net/kivy-appl ... -tutorial/) erwähnt dieses Problem nicht, und in der Paketverwaltung finde ich zwar viele Zusatzprogramme zu SDL (Ruby SDL, Haskell SDL, Perl SDL, usw), nur einfaches SDL oder (Python-SDL?) ist anscheinend nicht vorhanden. Wie mache ich nun weiter?
BlackJack

Sonntag 5. März 2017, 00:57

@Goswin: Gibt es Pygame nicht in der Paketverwaltung (python-pygame in Debian)? Du brauchst das Paket für die `libsdl` das die Headerdateien enthält (`libsdl1.2-dev` in Debian). Da Pygame auch noch ein paar von den anderen SDL-Zusatzbibliotheken verwendet, müssten die und deren dev-Pakete auch installiert werden.
Benutzeravatar
Goswin
User
Beiträge: 361
Registriert: Freitag 8. Dezember 2006, 11:47
Wohnort: Ulm-Böfingen

Sonntag 5. März 2017, 01:20

BlackJack hat geschrieben:@Goswin: Du brauchst das Paket für die `libsdl` das die Headerdateien enthält (`libsdl1.2-dev` in Debian). Da Pygame auch noch ein paar von den anderen SDL-Zusatzbibliotheken verwendet, müssten die und deren dev-Pakete auch installiert werden.
Ja, jetzt habe ich "libsdl1.2-dev" in der Paketverwaltung entdeckt. Und siehe: es war bereits installiert, als sdl-config nicht gefunden wurde! Ich nehme nun an, dass sdl-config wegen fehlender SDL-Zusatzbibliotheken nicht zu finden ist, aber wie heißen diese Zusatzbibliotheken? Ohne diese Info kann ich sie nicht installieren, da die Paketverwaltung seitenweise Programme enthält, die "sdl" im Namen tragen.
BlackJack

Sonntag 5. März 2017, 02:02

@Goswin: Also bei mir ist /usr/bin/sdl-config im Paket libsdl1.2-dev enthalten. :K
Benutzeravatar
Goswin
User
Beiträge: 361
Registriert: Freitag 8. Dezember 2006, 11:47
Wohnort: Ulm-Böfingen

Sonntag 5. März 2017, 02:18

BlackJack hat geschrieben:@Goswin: Also bei mir ist /usr/bin/sdl-config im Paket libsdl1.2-dev enthalten. :K
Da waren noch zusätzliche Fehlermeldungen bei mir; die vollständige Ausgabe ist:

WARNING, No "Setup" File Exists, Running "config.py"
Using UNIX configuration...

sh: 1: sdl-config: not found

Hunting dependencies...
WARNING: "sdl-config" failed!
Unable to run "sdl-config". Please make sure a development version of SDL is installed.


Ich habe mir noch ein anderes Tutorium für Kivy angeschaut, wo von pygame nicht (offen) die Rede ist. Brauche ich WIRKLICH pygame wenn ich Kivy benutzen möchte? Und wenn ja, brauche ich dafür WIRKLICH die "development version" von SDL oder ist das nur eine Empfehlung eifriger Avantgardisten?
BlackJack

Sonntag 5. März 2017, 04:08

@Goswin: dev-Pakete enthalten keine „development version“ sondern die Headerdateien und was man sonst noch so braucht um die entsprechende Bibliothek in selbst compilierten Programmen zu benutzen. Das ”nicht-dev”-Paket installiert nur die Bibliothek, so dass die von bereits kompilierten Programmen verwendet werden kann.

Das `libsdl1.2-dev`-Paket enthält beispielsweise das `sdl-config`-Skript, die Headerdateien die der C-Compiler benötigt um C-Programme zu übersetzen die Strukturen und Funktionen von SDL verwenden (in /usr/include/SDL/*.h), die Dokumentation zu den Strukruren und Funktionen als HTML (/usr/share/doc/libsdl1.2-dev/docs/html/index.html) und manpages und ein paar Beispielquelltexte.
Benutzeravatar
snafu
User
Beiträge: 5498
Registriert: Donnerstag 21. Februar 2008, 17:31
Wohnort: Gelsenkirchen

Sonntag 5. März 2017, 09:53

Goswin hat geschrieben:Ich benutze Linux Mint 13 Maya, und habe versucht, pygame mit
"pip install pygame" zu installieren.
Warum installierst du nicht einfach das entsprechende Linux Mint Paket?

https://community.linuxmint.com/softwar ... hon-pygame
shcol (Repo | Doc | PyPi)
Antworten