Django läßt sich nicht installieren

Python auf Einplatinencomputer wie Raspberry Pi, Banana Pi / Python für Micro-Controller
Antworten
Benutzeravatar
JiPi
User
Beiträge: 2
Registriert: Dienstag 23. Januar 2018, 22:35

Dienstag 23. Januar 2018, 22:53

Hi,

Ich versuche für den PiCar von Sunfounder die Handysteuerung in Betrieb zu nehmen und scheitere an der Insatllation von Django

Beim angegebenen Versuch mit "sudo pip install Django"

kommt der Fehler des "Unsupported Version of Python" http://www.bilder-upload.eu/show.php?fi ... 577506.png

pip ist up to date ( 9.01 )

mit "django<2" wird dann Django 1.11.9 installiert, aber beim Aufruf von manage.py erscheint der Fehler "No Module django.core.mangement"
also wohl das falsche Django.

Mein Versuch diesen Fehler im Netz zu finden, schlug fehl. Offensichtlich bin ich der Einzige den Django nich mag :-(

Python 3.4 ist installiert: http://www.bilder-upload.eu/show.php?fi ... 578755.png

Meine Boardinfos: http://www.bilder-upload.eu/show.php?fi ... 578715.png


Ich hab keine Idee mehr, bitte um Hilfe
Danke
__deets__
User
Beiträge: 3102
Registriert: Mittwoch 14. Oktober 2015, 14:29

Dienstag 23. Januar 2018, 23:09

Du benutzt das falsche pip. Du musst pip3 nehmen. Oder statt pip „python3.4 -m pip install ...“
Benutzeravatar
JiPi
User
Beiträge: 2
Registriert: Dienstag 23. Januar 2018, 22:35

Dienstag 23. Januar 2018, 23:44

vielen Dank deets für die rasante Antwort

Installation hat geklappt. Danach gab´s ne Fehlermeldung mit dem Hinweis auf eine Migration. Die hab ich gemacht und dann kamen Fehler "Error: Inappropite ioctl for device
Dann einfach nochmal manage.py aufgerufen und nu klappts. Wirkt ein bißchen wie Wunderheilung.

Vielen Dank und Grüße
Antworten