Seite 1 von 1

PyQt mit Mandrake 9.0

Verfasst: Mittwoch 4. Dezember 2002, 14:22
von koegli
Ich versuche (verzweifelt) PyQt in einer Mandrake 9.0 Umgebung zu installieren.

Kompilation funktioniert problemlos, auch nach dn README.linux patches, jedoch bekomme ich bei der Exekution der Beispielprogramme immer den Fehler: ImportError aus libqtmodule.so, undefined reference zu einem bestimmten SGIStyle-Objekt. Kann mir jemand helfen?


NIC

Verfasst: Mittwoch 4. Dezember 2002, 18:43
von hans
Hallo Koegli,

habe selbst keinen Plan von Mandrake und schon garnicht vom Compilieren. Kannst du nicht fertige RPM's installieren? Ich finde bei http://www.rpmfind.net jede Menge fertige Binaries für Mandrake. Die Installation ist dann denkbar einfach:

Code: Alles auswählen

rpm -ivh PyQt......rpm
Vorteil dieser Vorgehnsweise: RPM sagt dir, welch zusätzlichen Pakete fehlen.

Hans

Eigenes Qt kompilieren

Verfasst: Donnerstag 5. Dezember 2002, 01:09
von Mickey
Servus, die Qt-Version von Mandrake ist gepatched. Du solltest Dir eine eigene Qt-Version kompilieren und mit dieser dann sip und PyQt.

Die Alternative sind RPMS.

PyQt mit Mandrake 9.0

Verfasst: Donnerstag 5. Dezember 2002, 16:21
von Koegli
Danke,

das ist wohl die Loesung. RPMs.

Ich habe ein altes Laptop und bisher SuSe Linux 7.0 benutzt. Deshalb kompiliere ich alles selber, um eine bessere Performance zu bekommen. Wollte Mandrake eine Chance geben, da ich 9.0 billig bekommen habe. Bin aber eher entsetzt. Sobald Du etwas mehr unter die Haube schaust, funktionert ohne Bastelei gar nichts!

Danke,

NIC (koegli ist meine EMail)

Verfasst: Donnerstag 5. Dezember 2002, 21:51
von hans
Also meine erste SuSE war 6.1 Habe mich dann so reingefriemelt. War garnicht so schwer wegen 15 Jahren Shellerfahrung (Konfiguration habe ich bis dato aber immer andere machen lassen)

Also wenn mir dass mit Yast zu blöd wird, dann ziehe ich mir mal eben eine RPM und knall sie ins System. Bei etwas sorgfältiger Selektion der Quellen habe ich das immer zum Laufen gebracht.

Code: Alles auswählen

rpm -ivh *.rpm
geht eben tausendmal schneller als Yast.

Hans

witzig!

Verfasst: Sonntag 8. Dezember 2002, 03:41
von Gast
an den gast!

du hast suse und meinst du musst bei mandrake basteln???

einfach witzig wie unterschiedlich die erfahrungen sind. bei mir lief suse nicht einen tag ohne einfrieren. ausserdem hat eigentlich nichts funktioniert. konqueror z.b. brauchte fast minuten um die verzeichnisse zu listen etc.

bei mandrake 9.0 habe ich nur das problem dass das fernsehbild bei 8.2 schon besser war.

naja, eigentlich egal

mfg

roland

PyQt mit Mandrake 9.0

Verfasst: Freitag 13. Dezember 2002, 15:19
von Koegli
Danke fuer die Tips,

Binaries funktionieren klasse.
Ich habe jetzt aber QT3.1 kompiliert. Hat jemand Erfahrung mit der neuesten PyQt Version 3.5 und eric, bevor ich wieder Naechte vorm PC verbringe.

Herzlichen Dank,

NIC