Fehler "ImportError: No module named 'gtk'"

Programmierung für GNOME und GTK+, GUI-Erstellung mit Glade.
Antworten
floppy
User
Beiträge: 6
Registriert: Samstag 9. Dezember 2017, 16:24

Donnerstag 21. Dezember 2017, 22:00

Guten Abend,
ich benutze gerade "Debian9" mit "Glade" 3.20 und "pycharm"; beim starten vom Skript

Code: Alles auswählen

#!/usr/bin/python3.5
import string
import os
import gtk
erscheint diese Fehlermeldung im Betreff.
Kann Jemand sagen was ich tun sollte um weiterzukommen?

Hinweis: mit

Code: Alles auswählen

#!/usr/bin/python3.5
import string
import os
from gi.repository import Gtk
gibt es die Meldung

Code: Alles auswählen

ImportError: No module named 'gi'
But no error with the command line:

Code: Alles auswählen

python3
Python 3.5.3 (default, Jan 19 2017, 14:11:04) 
[GCC 6.3.0 20170118] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import gi

Hinweise sind gerne willkommen.
floppy
User
Beiträge: 6
Registriert: Samstag 9. Dezember 2017, 16:24

Freitag 22. Dezember 2017, 10:19

Ergaenzung: die Ausfuehrung passierte innerhalb "pycharm community 2017.3.1" 64bit.
floppy
User
Beiträge: 6
Registriert: Samstag 9. Dezember 2017, 16:24

Freitag 22. Dezember 2017, 11:07

erledigt..

a) zu lesen https://stackoverflow.com/questions/375 ... da-python3
b) mit der code

Code: Alles auswählen

#!/usr/bin/python3.5
import string
import os
import gi
gi.require_version('Gtk', '3.0')
from gi.repository import Gtk
c) und Anwendung as root fuer mein Fall von ln -s /usr/lib/python3/dist-packages/gi /home/family/glade/scoreboard_uwr/venv/lib/python3.5/site-packages/

jetzt ist gtk geladen. Und nun kommt die naechste Fehlermeldungen. Das ist aber nix fuer diesen thread.
floppy
User
Beiträge: 6
Registriert: Samstag 9. Dezember 2017, 16:24

Freitag 22. Dezember 2017, 13:55

import gi
gi.require_version('Gtk', '3.0')
from gi.repository import Gtk as gtk

see https://askubuntu.com/questions/697397/ ... gtk-module
Antworten