CGI konfigurieren Ubuntu 18.04.

Probleme bei der Installation?
Antworten
mr_egbert
User
Beiträge: 9
Registriert: Montag 13. Januar 2020, 13:33

Mittwoch 20. Mai 2020, 10:19

Guten Morgen,

ich schaffe es nicht CGI richtig zu konfigurieren.

Da es keine httpd.conf gibt, habe ich zunächst in apache2.conf das Verzeichnis /var/www/cgi-bin eingetragen.
Beim Aufrufen (www. *** /cgi-bin/name.py) kam die Fehlermeldung 'url not found. Das habe ich inzwischen wieder auskommentiert.

Ich bin dann auf eine andere Anleitung gestoßen, die glaube ich besser passt:
In /etc/apache2/conf-available gibt es die Datei serve-cgi-bin.conf . Dort ist bereits das Verzeichnis /usr/lib/cgi-bin konfiguriert. Ich musste nur noch in /etc/apache2/mods-enabled einen Link zu /etc/apache2/mods-available/cgi.load erstellen.

Jetzt lautet die Fehlermeldung Internal Server Error (or misconfiguration) und ich weiß nicht weiter.

Kann jemand helfen?

In serve-cgi-bin.conf steht:

Code: Alles auswählen

<IfModule mod_alias.c>
        <IfModule mod_cgi.c>
                Define ENABLE_USR_LIB_CGI_BIN
        </IfModule>

        <IfModule mod_cgid.c>
                Define ENABLE_USR_LIB_CGI_BIN
        </IfModule>

        <IfDefine ENABLE_USR_LIB_CGI_BIN>
                ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
                <Directory "/usr/lib/cgi-bin">
                        AllowOverride None
                        Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                        AddHandler cgi-script .cgi .pl .py
                        Require all granted
                </Directory>
        </IfDefine>
</IfModule>
Viele Grüße
Martin
Benutzeravatar
sparrow
User
Beiträge: 1839
Registriert: Freitag 17. April 2009, 10:28

Mittwoch 20. Mai 2020, 10:21

Die Antwort lautet: Vergiss CGI und nimm WSGI.
Benutzeravatar
__blackjack__
User
Beiträge: 6012
Registriert: Samstag 2. Juni 2018, 10:21
Wohnort: 127.0.0.1
Kontaktdaten:

Mittwoch 20. Mai 2020, 10:59

@mr_egbert: Wo(bei) bekommst Du denn die Fehlermeldung?
long long ago; /* in a galaxy far far away */
mr_egbert
User
Beiträge: 9
Registriert: Montag 13. Januar 2020, 13:33

Mittwoch 20. Mai 2020, 17:40

Problem gelöst: der / das Shebang im Skript war falsch. Es lag nicht an der Konfiguration.

Vielen Dank für die Rückmeldungen und sorry, dass ich unüberlegt ins Forum gepostet habe.

Allen einen schönen Feiertag.
LG
nezzcarth
User
Beiträge: 998
Registriert: Samstag 16. April 2011, 12:47

Mittwoch 20. Mai 2020, 17:45

mr_egbert hat geschrieben:
Mittwoch 20. Mai 2020, 17:40
Problem gelöst: der / das Shebang im Skript war falsch. Es lag nicht an der Konfiguration.
Du solltest dir trotzdem überlegen, ob du nicht sparrows Vorschlag aufgreifen möchtest, denn CGI ist verstaubte Technologie aus der Urzeit der Anfangszeit der Webentwicklung. Das sollte man nicht mehr nehmen, wenn man nicht unbedingt muss.
mr_egbert
User
Beiträge: 9
Registriert: Montag 13. Januar 2020, 13:33

Mittwoch 20. Mai 2020, 18:45

Ja, ich werde mir WSGI auf jeden Fall ansehen.
Antworten