BeautifulSoup wird nicht gefunden

Probleme bei der Installation?
Antworten
Pythagon
User
Beiträge: 41
Registriert: Mittwoch 3. Juli 2019, 18:21

Donnerstag 11. Juli 2019, 21:11

Hallo zusammen,

ich habe gerade auf GitHub einen Installer für BeautifulSoup gezogen und das Modul über die Eingabeaufforderung (Windows 8/Python 3.7.3) installiert. Das entsprechende Library wurde auch erstellt, trotzdem bekomme ich bei dem Versuch bs4 zu importieren einen Fehler:
>>> from bs4 import BeautifulSoup
Traceback (most recent call last):
File "<pyshell#6>", line 1, in <module>
from bs4 import BeautifulSoup
File "C:\Users\Herbert_Meisel\AppData\Local\Programs\Python\Python37-32\lib\site-packages\bs4\__init__.py", line 30, in <module>
from .builder import builder_registry, ParserRejectedMarkup
File "C:\Users\Herbert_Meisel\AppData\Local\Programs\Python\Python37-32\lib\site-packages\bs4\builder\__init__.py", line 308, in <module>
from . import _htmlparser
File "C:\Users\Herbert_Meisel\AppData\Local\Programs\Python\Python37-32\lib\site-packages\bs4\builder\_htmlparser.py", line 7, in <module>
from html.parser import (
ImportError: cannot import name 'HTMLParseError' from 'html.parser' (C:\Users\Herbert_Meisel\AppData\Local\Programs\Python\Python37-32\lib\html\parser.py)
Hat jemand eine Ahnung woran das liegen könnte?

Beste Grüße,
Marc
Benutzeravatar
kbr
User
Beiträge: 1069
Registriert: Mittwoch 15. Oktober 2008, 09:27

Donnerstag 11. Juli 2019, 22:10

Da hast Du vermutlich eine veraltete Version von BS gezogen. Der HTMLParseError ist seit Python 3.3 deprecated und in aktuellen Python Versionen auch nicht mehr definiert.
Pythagon
User
Beiträge: 41
Registriert: Mittwoch 3. Juli 2019, 18:21

Donnerstag 11. Juli 2019, 22:26

kbr hat geschrieben:
Donnerstag 11. Juli 2019, 22:10
Da hast Du vermutlich eine veraltete Version von BS gezogen. Der HTMLParseError ist seit Python 3.3 deprecated und in aktuellen Python Versionen auch nicht mehr definiert.
Ja, das hatte ich auch gelesen aber nachdem ich nun Python 3.5 installiert habe und BeautifulSoup 4.4.0 ist das ergebnis trotzdem noch das Gleiche obwohl es in verschiedenen Foren hieß damit könne das Problem gelöst werden. Es ist ärgerlich.

Welches wäre denn die neueste Version von BeautifulSoup?
Benutzeravatar
kbr
User
Beiträge: 1069
Registriert: Mittwoch 15. Oktober 2008, 09:27

Donnerstag 11. Juli 2019, 22:40

Mit ein wenig Googeln kannst Du schnell herausfinden, dass die aktuelle Version 4.7.1 ist. Bleibe bei der aktuellen Python 3.7 Version und installiere BS per pip oder conda. Dann bist Du auf der sicheren Seite.
Pythagon
User
Beiträge: 41
Registriert: Mittwoch 3. Juli 2019, 18:21

Freitag 12. Juli 2019, 18:47

kbr hat geschrieben:
Donnerstag 11. Juli 2019, 22:40
Mit ein wenig Googeln kannst Du schnell herausfinden, dass die aktuelle Version 4.7.1 ist. Bleibe bei der aktuellen Python 3.7 Version und installiere BS per pip oder conda. Dann bist Du auf der sicheren Seite.
Ich hatte zunächst gegoogelt aber war mir nicht sicher. Ich habe jetzt Python 3.7.4 wieder installiert und BS 4.7.1 und es klappt trotzdem nicht.

Zugegeben, ich habe es wieder über die Eingabeaufforderung installiert. Mir leuchtet nicht ein wo der Unterschied sein soll denn man könnte doch davon ausgehen, dass es entweder kompatibel ist oder eben nicht aber anscheinend ist die Installation von Modulen eine Wissenschaft für sich.

Wenn ich den Anleitungen folge wie man Module mit Hilfe von pip installiert klappt es überhaupt nicht weil ich ständig die Mitteilung bekomme, die Syntax wäre falsch obwohl pip ja in Version 3.x bereits vorinstalliert sein müsste. Es ist wirklich zum Haare raufen. Ich lade jetzt gerade Conda herunter und bin gespannt was mich damit wieder erwartet.
Pythagon
User
Beiträge: 41
Registriert: Mittwoch 3. Juli 2019, 18:21

Freitag 12. Juli 2019, 19:25

kbr hat geschrieben:
Donnerstag 11. Juli 2019, 22:40
Mit ein wenig Googeln kannst Du schnell herausfinden, dass die aktuelle Version 4.7.1 ist. Bleibe bei der aktuellen Python 3.7 Version und installiere BS per pip oder conda. Dann bist Du auf der sicheren Seite.
Danke für den Tipp mit Conda. Nach der Installation war BS4 sofort verfügbar und die Spyder Umgebung ist auch sehr praktisch.

Beste Grüße!
Antworten