Versuch scikit_image zu installieren schlägt fehl

Probleme bei der Installation?
Antworten
CodeIt
User
Beiträge: 26
Registriert: Mittwoch 13. September 2017, 06:10

Donnerstag 7. Februar 2019, 20:49

Hallo, ich versuche scikit_image mit pip install zu installieren, erhalte jedoch folgende Fehlermeldung (numpy und skipy sind installiert):

Code: Alles auswählen

 Could not find a version that satisfies the requirement dask[array]>=1.0.0 (fr
om scikit-image==0.14.2) (from versions: 0.7.4.linux-x86_64, 0.7.5.linux-x86_64,
 0.7.6.linux-x86_64, 0.8.1.macosx-10.5-x86_64, 0.2.0, 0.2.1, 0.2.2, 0.2.3, 0.2.4
, 0.2.5, 0.2.6, 0.3.0, 0.4.0, 0.5.0, 0.6.0, 0.6.1, 0.7.0, 0.7.1, 0.7.2, 0.7.3, 0
.7.4, 0.7.5, 0.7.6, 0.8.0, 0.8.1, 0.8.2, 0.9.0, 0.10.0, 0.10.1, 0.10.2, 0.11.0,
0.11.1, 0.12.0, 0.13.0rc1, 0.13.0, 0.14.0, 0.14.1, 0.14.2, 0.14.3, 0.15.0, 0.15.
1, 0.15.2, 0.15.3, 0.15.4, 0.16.0, 0.16.1, 0.17.0, 0.17.1, 0.17.2, 0.17.3, 0.17.
4, 0.17.5, 0.18.0, 0.18.1, 0.18.2)
No matching distribution found for dask[array]>=1.0.0 (from scikit-image==0.14.2
)
You are using pip version 18.1, however version 19.0.1 is available.
You should consider upgrading via the 'python -m pip install --upgrade pip' comm
and.
Weiß jemand Rat? Wäre für jeden Tipp dankbar.

Die komplette Ausgabe lautet wie folgt:

Code: Alles auswählen

C:\Python34\Scripts>cmd
Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. Alle Rechte vorbehalten.

C:\Python34\Scripts>pip install -U scikit_image-0.14.2-cp34-cp34m-win32.whl
Processing c:\python34\scripts\scikit_image-0.14.2-cp34-cp34m-win32.whl
Requirement already satisfied, skipping upgrade: networkx>=1.8 in c:\python34\li
b\site-packages (from scikit-image==0.14.2) (2.0)
Collecting cloudpickle>=0.2.1 (from scikit-image==0.14.2)
  Downloading https://files.pythonhosted.org/packages/34/80/66d06012248d7a8d3caf
8c52937d435371336fb1161eb919ff6a57dccc70/cloudpickle-0.7.0-py2.py3-none-any.whl
Collecting PyWavelets>=0.4.0 (from scikit-image==0.14.2)
  Using cached https://files.pythonhosted.org/packages/b4/42/074c6adcd1586926650
d8365bcc3e1ab42f81a68c620c4242aa9297b01d9/PyWavelets-1.0.1.tar.gz
Collecting dask[array]>=1.0.0 (from scikit-image==0.14.2)
  Could not find a version that satisfies the requirement dask[array]>=1.0.0 (fr
om scikit-image==0.14.2) (from versions: 0.7.4.linux-x86_64, 0.7.5.linux-x86_64,
 0.7.6.linux-x86_64, 0.8.1.macosx-10.5-x86_64, 0.2.0, 0.2.1, 0.2.2, 0.2.3, 0.2.4
, 0.2.5, 0.2.6, 0.3.0, 0.4.0, 0.5.0, 0.6.0, 0.6.1, 0.7.0, 0.7.1, 0.7.2, 0.7.3, 0
.7.4, 0.7.5, 0.7.6, 0.8.0, 0.8.1, 0.8.2, 0.9.0, 0.10.0, 0.10.1, 0.10.2, 0.11.0,
0.11.1, 0.12.0, 0.13.0rc1, 0.13.0, 0.14.0, 0.14.1, 0.14.2, 0.14.3, 0.15.0, 0.15.
1, 0.15.2, 0.15.3, 0.15.4, 0.16.0, 0.16.1, 0.17.0, 0.17.1, 0.17.2, 0.17.3, 0.17.
4, 0.17.5, 0.18.0, 0.18.1, 0.18.2)
No matching distribution found for dask[array]>=1.0.0 (from scikit-image==0.14.2
)
You are using pip version 18.1, however version 19.0.1 is available.
You should consider upgrading via the 'python -m pip install --upgrade pip' comm
and.

C:\Python34\Scripts>
Benutzeravatar
sparrow
User
Beiträge: 1315
Registriert: Freitag 17. April 2009, 10:28

Donnerstag 7. Februar 2019, 21:18

Schau mal hier: https://pypi.org/project/dask/
Offensichtlich funktioniert dask nicht mit Python 3.4.
Du solltest auf eine neuere Version, sprich am besten direkt 3.7, upgraden.
CodeIt
User
Beiträge: 26
Registriert: Mittwoch 13. September 2017, 06:10

Donnerstag 7. Februar 2019, 21:29

Vielen Dank. Dann werde ich mal upgraden auf 3.7.
CodeIt
User
Beiträge: 26
Registriert: Mittwoch 13. September 2017, 06:10

Donnerstag 7. Februar 2019, 23:17

scikit_image lässt sich jetzt unter Python 3.7 installieren,....aber Tensorflow lässt sich nicht mehr installieren.
Hat jemand eine Idee ?
__deets__
User
Beiträge: 6189
Registriert: Mittwoch 14. Oktober 2015, 14:29

Freitag 8. Februar 2019, 00:49

Ohne Fehlermeldung und genaue Beschreibung was du tust - nein.
Benutzeravatar
__blackjack__
User
Beiträge: 4009
Registriert: Samstag 2. Juni 2018, 10:21
Wohnort: 127.0.0.1
Kontaktdaten:

Freitag 8. Februar 2019, 06:17

Ich denke mal jetzt gibt's genau das gegenteilige Problem: Python 3.7 ist für Tensorflow zu neu. Pypi sagt Python 3.4 bis 3.6 werden unterstützt. :-)
“Programmieren ist ein Hobby, bei dem es einen riesigen Baumarkt mit quasi jedem Bauteil und Werkzeug und fast immer kostenlos gibt. Ob man deswegen in der Lage ist einen Kölner Dom zu bauen ist eine andere Frage. Arbeit steckt auf jeden Fall drin ;).” — Greebo, forum.ubuntuusers.de
__deets__
User
Beiträge: 6189
Registriert: Mittwoch 14. Oktober 2015, 14:29

Freitag 8. Februar 2019, 14:12

"Computer helfen uns Probleme zu loesen, die wir ohne sie nicht haetten"...
Antworten