Fehler bei pip Instalation

Probleme bei der Installation?
Antworten
PyFM
User
Beiträge: 9
Registriert: Donnerstag 4. Januar 2018, 10:04
Kontaktdaten:

Montag 2. Juli 2018, 21:30

Hallo,
ich versuche seit geraumer Zeit pip in python27 zu instalieren, jedoch tritt bei der instalation mit get-pip.py immer ein fehler auf...
Was mache ich falsch?

Hier der Fehler der ausgegeben wird:

Code: Alles auswählen

Collecting pip
[33m  Retrying (Retry(total=4, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError(SSLError(1, '_ssl.c:504: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version'),)': /simple/pip/[0m
[33m  Retrying (Retry(total=3, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError(SSLError(1, '_ssl.c:504: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version'),)': /simple/pip/[0m
[33m  Retrying (Retry(total=2, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError(SSLError(1, '_ssl.c:504: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version'),)': /simple/pip/[0m
[33m  Retrying (Retry(total=1, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError(SSLError(1, '_ssl.c:504: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version'),)': /simple/pip/[0m
[33m  Retrying (Retry(total=0, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError(SSLError(1, '_ssl.c:504: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version'),)': /simple/pip/[0m
  Could not fetch URL https://pypi.org/simple/pip/: There was a problem confirming the ssl certificate: HTTPSConnectionPool(host='pypi.org', port=443): Max retries exceeded with url: /simple/pip/ (Caused by SSLError(SSLError(1, '_ssl.c:504: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version'),)) - skipping
[31m  Could not find a version that satisfies the requirement pip (from versions: )[0m
[31mNo matching distribution found for pip[0m
Danke für eure Hilfe
PyFM
__deets__
User
Beiträge: 3980
Registriert: Mittwoch 14. Oktober 2015, 14:29

Montag 2. Juli 2018, 21:39

PyFM
User
Beiträge: 9
Registriert: Donnerstag 4. Januar 2018, 10:04
Kontaktdaten:

Montag 2. Juli 2018, 22:02

You may want to add the trusted hosts and proxy to your config file.

pip.ini (Windows) or pip.conf (unix)

[global]
trusted-host = pypi.python.org
pypi.org
files.pythonhosted.org
Ich habe pip doch noch garnicht installiert. (Das Funktioniert ja nicht.)
was soll ich also tun?
__deets__
User
Beiträge: 3980
Registriert: Mittwoch 14. Oktober 2015, 14:29

Montag 2. Juli 2018, 22:14

Ups. Stimmt. Na du kannst das, was getpip macht, ja auch selbst machen. Also eine Datei mit dem Browser runter laden, und dann die folgenden Schritte tun. Einfach anschauen was getpip macht.

Oder den auch beschriebenen weg gehen, die Zertifikate einzutragen. Damit SSL die akzeptiert.
PyFM
User
Beiträge: 9
Registriert: Donnerstag 4. Januar 2018, 10:04
Kontaktdaten:

Dienstag 3. Juli 2018, 11:12

Habe es jetzt geschafft pip zu installieren. Jedoch kommt, wenn ich versuche ein Module zu installieren, folgende Fehlermeldung:
_____________________
Traceback (most recent call last):
File "C:\Python27\Scripts\pip-script.py", line 11, in <module>
load_entry_point('pip==10.0.1', 'console_scripts', 'pip')()
File "build\bdist.win32\egg\pkg_resources\__init__.py", line 476, in load_entry_point
File "build\bdist.win32\egg\pkg_resources\__init__.py", line 2700, in load_entry_point
File "build\bdist.win32\egg\pkg_resources\__init__.py", line 2318, in load
File "build\bdist.win32\egg\pkg_resources\__init__.py", line 2324, in resolve
File "C:\Python27\lib\site-packages\pip-10.0.1-py2.7.egg\pip\_internal\__init__.py", line 20, in <module>
from pip._vendor.urllib3.exceptions import DependencyWarning
File "C:\Python27\lib\site-packages\pip-10.0.1-py2.7.egg\pip\_vendor\urllib3\__init__.py", line 8, in <module>
from .connectionpool import (
ImportError: No module named connectionpool
_____________________
Was muss ich tun, um den Fehler zu beheben?
__deets__
User
Beiträge: 3980
Registriert: Mittwoch 14. Oktober 2015, 14:29

Dienstag 3. Juli 2018, 11:20

Was ist denn so alles in dem Verzeichnis von urllib3, das in der Fehlermeldung steht? Wenn du solche Fehler siehst, kannst du uebrigens auch problemlos mal selber nachschauen, was die Fehlermeldung ausspuckt und an die Stellen gucken, die da drin erwaehnt werden. Das ist alles nur Python-Code.
Hofei
User
Beiträge: 14
Registriert: Freitag 6. Januar 2017, 20:15

Dienstag 3. Juli 2018, 13:46

Hallo,
ich nahm für Windows den bequemen Weg und Griff auf Anaconda zurück:
https://www.anaconda.com/download/
Allerdings mit V3 (natürlich). Ob bei V2 auch standardmäßig pip enthalten ist, kann ich nicht beurteilen.
Benutzeravatar
__blackjack__
User
Beiträge: 1558
Registriert: Samstag 2. Juni 2018, 10:21

Dienstag 3. Juli 2018, 14:28

Warum überhaupt pip für 2.7 installieren? Seit Version 2.7.9 ist pip direkt dabei, ich würde also eher Python 2.7 aktualisieren bevor ich pip für ein altes 2.7 extra installiere.

Code: Alles auswählen

    **** COMMODORE 64 BASIC V2 ****
 64K RAM SYSTEM  38911 BASIC BYTES FREE
   CYBERPUNX RETRO REPLAY 64KB - 3.8P
READY.
█
Antworten