Pandas + Numpy AttributeError

Probleme bei der Installation?
Sparkobabble
User
Beiträge: 1
Registriert: Donnerstag 18. Januar 2018, 12:31

Pandas + Numpy AttributeError

Beitragvon Sparkobabble » Donnerstag 18. Januar 2018, 12:40

Hallo erstmal,
Ich bin neu hier, tut mir also Leid wenn ich was falsch angehe :oops:
Ich habe ein Problem beim importieren von Pandas und weiß mir nicht zu helfen, da ich nicht wirklich die Ahnung von Python (und generell) hab :(
Ich möchte auf meinem Raspberry Pi in einem Python Skript (zu Testzwecken) einfach nur per "import pandas as pandas" pandas importieren
Dabei erhalte ich jedoch folgenden Fehler, welcher scheinbar was mit Numpy, zusammenhängt.
Ich habe mal ein Bild von der Fehlermeldung angehangen.
Bild
https://imgur.com/0eb3gjo
Vielleicht kann mir ja jemand mit meinem Halbwissen weiterhelfen..
Grüße Sparkobabble
Benutzeravatar
noisefloor
User
Beiträge: 2235
Registriert: Mittwoch 17. Oktober 2007, 21:40
Wohnort: Görgeshausen
Kontaktdaten:

Re: Pandas + Numpy AttributeError

Beitragvon noisefloor » Donnerstag 18. Januar 2018, 15:05

Hallo,

wie hast du pandas? Installiert? Der Installationspfad in der Fehlermeldung ist merkwürdig...

`import pandas as pandas` Quatsch, das ist das gleiche wie `import pandas`, nur letzteres ist weniger umständlich.

Gruß, noisefloor
narpfel
User
Beiträge: 146
Registriert: Freitag 20. Oktober 2017, 16:10

Re: Pandas + Numpy AttributeError

Beitragvon narpfel » Donnerstag 18. Januar 2018, 15:06

Moin,

wie hast du denn `pandas` und `numpy` installiert?

Bitte poste Fehlermeldungen und Code nicht als Screenshots (auch der Raspberry Pi kann richtige Screenshots), sondern hier in Codebox-Tags (Dropdown-Menü „Code auswählen“ direkt über dem Editor-Fenster) als Text per Copy-Paste, sonst ist die Fehlersuche sehr viel schwerer, weil man den Code nicht einfach ausführen kann.

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder