PyNaCl zusammenbauen und installieren

Probleme bei der Installation?
may24x
User
Beiträge: 39
Registriert: Montag 2. September 2013, 06:44

PyNaCl zusammenbauen und installieren

Beitragvon may24x » Donnerstag 12. Oktober 2017, 10:05

Hallo zusammen.

Ich versuche derzeit ansible auf meinem Cygwin zum laufen zu bringen.
Dafür wird (unter andem) PyNaCl gebraucht.
Leider ist meine Internet Connectivity stark eingeschränkt ... soll heißen: Ich kann nichts via pip und Co installieren. Nur Pakete via Browser runterladen.

PyNaCl braucht als Abhängigkeit cffi. Das Paket src Paket (cffi-1.11.2.tar.gz) habe ich auch runtergeladen und installiert mit:

Code: Alles auswählen

python setup.py install

Ist auch soweit durchgelaufen ohne Probleme/Fehler.
Aktuell verwende ich Python 2.7
Dann aber versuche ich PyNaCl zusammenzusetzen und ...

Code: Alles auswählen

$ python setup.py install
Download error on http://pypi.python.org/simple/cffi/: [Errno 114] Network is unreachable -- Some packages may not be found!
Download error on http://pypi.python.org/simple/cffi/: [Errno 114] Network is unreachable -- Some packages may not be found!
Couldn't find index page for 'cffi' (maybe misspelled?)
Download error on http://pypi.python.org/simple/: [Errno 114] Network is unreachable -- Some packages may not be found!
No local packages or download links found for cffi>=1.4.1
Traceback (most recent call last):
  File "setup.py", line 232, in <module>
    "Programming Language :: Python :: 3.6",
  File "/usr/lib/python2.7/distutils/core.py", line 112, in setup
    _setup_distribution = dist = klass(attrs)
  File "/usr/lib/python2.7/site-packages/setuptools/dist.py", line 221, in __init__
    self.fetch_build_eggs(attrs.pop('setup_requires'))
  File "/usr/lib/python2.7/site-packages/setuptools/dist.py", line 245, in fetch_build_eggs
    parse_requirements(requires), installer=self.fetch_build_egg
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 586, in resolve
    dist = best[req.key] = env.best_match(req, self, installer)
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 831, in best_match
    return self.obtain(req, installer) # try and download/install
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 843, in obtain
    return installer(requirement)
  File "/usr/lib/python2.7/site-packages/setuptools/dist.py", line 295, in fetch_build_egg
    return cmd.easy_install(req)
  File "/usr/lib/python2.7/site-packages/setuptools/command/easy_install.py", line 592, in easy_install
    raise DistutilsError(msg)
distutils.errors.DistutilsError: Could not find suitable distribution for Requirement.parse('cffi>=1.4.1')


Warum wird das cffi nicht gefunden ???
Dessen Version ist 1.11.2 und liegt in /usr/lib/python2.7/site-packages/cffi ...

Code: Alles auswählen

$ ls -l  /usr/lib/python2.7/site-packages/cffi
total 632
-rw-r--r-- 1 MNC090 Domain Users   479 Oct  9 14:33 __init__.py
-rw-r--r-- 1 MNC090 Domain Users   534 Oct 12 10:20 __init__.pyc
-rw-r--r-- 1 MNC090 Domain Users 40221 Oct  9 14:33 api.py
-rw-r--r-- 1 MNC090 Domain Users 37386 Oct 12 10:20 api.pyc
-rw-r--r-- 1 MNC090 Domain Users 42086 Oct  9 14:33 backend_ctypes.py
-rw-r--r-- 1 MNC090 Domain Users 46738 Oct 12 10:20 backend_ctypes.pyc
-rw-r--r-- 1 MNC090 Domain Users  5724 Oct  9 14:33 cffi_opcode.py
-rw-r--r-- 1 MNC090 Domain Users  5965 Oct 12 10:20 cffi_opcode.pyc
-rw-r--r-- 1 MNC090 Domain Users  2689 Oct  9 14:33 commontypes.py
-rw-r--r-- 1 MNC090 Domain Users  2376 Oct 12 10:20 commontypes.pyc
-rw-r--r-- 1 MNC090 Domain Users 39250 Oct  9 14:33 cparser.py
-rw-r--r-- 1 MNC090 Domain Users 25487 Oct 12 10:20 cparser.pyc
-rw-r--r-- 1 MNC090 Domain Users   666 Oct  9 14:33 error.py
-rw-r--r-- 1 MNC090 Domain Users  1518 Oct 12 10:20 error.pyc
-rw-r--r-- 1 MNC090 Domain Users  4046 Oct  9 14:33 ffiplatform.py
-rw-r--r-- 1 MNC090 Domain Users  4591 Oct 12 10:20 ffiplatform.pyc
-rw-r--r-- 1 MNC090 Domain Users   747 Oct  9 14:33 lock.py
-rw-r--r-- 1 MNC090 Domain Users   439 Oct 12 10:20 lock.pyc
-rw-r--r-- 1 MNC090 Domain Users 21495 Oct  9 14:33 model.py
-rw-r--r-- 1 MNC090 Domain Users 23875 Oct 12 10:20 model.pyc
-rw-r--r-- 1 MNC090 Domain Users 63035 Oct  9 14:33 recompiler.py
-rw-r--r-- 1 MNC090 Domain Users 55403 Oct 12 10:20 recompiler.pyc
-rw-r--r-- 1 MNC090 Domain Users  7463 Oct  9 14:33 setuptools_ext.py
-rw-r--r-- 1 MNC090 Domain Users  7960 Oct 12 10:20 setuptools_ext.pyc
-rw-r--r-- 1 MNC090 Domain Users 41470 Oct  9 14:33 vengine_cpy.py
-rw-r--r-- 1 MNC090 Domain Users 37583 Oct 12 10:20 vengine_cpy.pyc
-rw-r--r-- 1 MNC090 Domain Users 26676 Oct  9 14:33 vengine_gen.py
-rw-r--r-- 1 MNC090 Domain Users 24543 Oct 12 10:20 vengine_gen.pyc
-rw-r--r-- 1 MNC090 Domain Users 11180 Oct  9 14:33 verifier.py
-rw-r--r-- 1 MNC090 Domain Users 11146 Oct 12 10:20 verifier.pyc
Benutzeravatar
__deets__
User
Beiträge: 1100
Registriert: Mittwoch 14. Oktober 2015, 14:29

Re: PyNaCl zusammenbauen und installieren

Beitragvon __deets__ » Donnerstag 12. Oktober 2017, 11:44

Vielleicht machen easy_install und pip irgendwas unterschiedlich, und darum findet der eine den anderen nicht. Das zu debuggen ist anstrengend.

Aber ich wuerde einfach mal das cffi-requirement raussschmeissen aus der setup.py und schauen, ob das installiert pynacl dann tut.
may24x
User
Beiträge: 39
Registriert: Montag 2. September 2013, 06:44

Re: PyNaCl zusammenbauen und installieren

Beitragvon may24x » Donnerstag 12. Oktober 2017, 12:03

Braucht Ansible das cffi nicht ?
Zuletzt geändert von may24x am Donnerstag 12. Oktober 2017, 12:11, insgesamt 1-mal geändert.
Benutzeravatar
__deets__
User
Beiträge: 1100
Registriert: Mittwoch 14. Oktober 2015, 14:29

Re: PyNaCl zusammenbauen und installieren

Beitragvon __deets__ » Donnerstag 12. Oktober 2017, 12:07

Natuerlich braucht es das. Aber du *hast* es ja. Wenn das setup darueber konfus ist, dann heisst das ja nicht, dass es im laufenden Betrieb nicht klappt. Das musst du halt ausprobieren.
may24x
User
Beiträge: 39
Registriert: Montag 2. September 2013, 06:44

Re: PyNaCl zusammenbauen und installieren

Beitragvon may24x » Donnerstag 12. Oktober 2017, 12:27

Nun, in der Tat es hat geklappt. Die cffi Abhängigheit rausgeworfen und schon klappt's mit dem installieren.
Merkwürdigerweise wurde z.B. six anstandslos gefunden ... und das wurde genauso installiert (aus dem tar.gz)
may24x
User
Beiträge: 39
Registriert: Montag 2. September 2013, 06:44

Re: PyNaCl zusammenbauen und installieren

Beitragvon may24x » Donnerstag 12. Oktober 2017, 12:53

Hm ... irgendwas ist scheinbar bei der cffi Installation schief gelaufen ...
Ich hab's nochmal drüber installiert und jetzt wird's auch gefunden.

Danke für die Hilfe

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder