Installation von TensorFlow für Anaconda 4.3.1 64 auf Windows 10

Probleme bei der Installation?
aleph
User
Beiträge: 20
Registriert: Donnerstag 19. Januar 2017, 15:28

Installation von TensorFlow für Anaconda 4.3.1 64 auf Windows 10

Beitragvon aleph » Samstag 18. März 2017, 11:19

Ich will TensorFlow für Anaconda 4.3.1 64 Bit auf Windows 10 installieren. Hier ist die Anleitung: https://www.tensorflow.org/install/install_windows

Ich gehe nach "Installing with native pip" vor. pip3 finde ich auf meinem System nicht, also habe ich gemacht:

Code: Alles auswählen

C:\Anaconda\Scripts>pip install --upgrade tensorflow
Collecting tensorflow
  Could not find a version that satisfies the requirement tensorflow (from versions: )
No matching distribution found for tensorflow


Wie installiere ich nun TensorFlow?
aleph
User
Beiträge: 20
Registriert: Donnerstag 19. Januar 2017, 15:28

Re: Installation von TensorFlow für Anaconda 4.3.1 64 auf Windows 10

Beitragvon aleph » Samstag 18. März 2017, 12:31

Folgendes geht auch nicht:

Code: Alles auswählen

C:\Anaconda\Scripts>pip install --ignore-installed --upgrade https://storage.googleapis.com/tensorflow/windows/cpu/tensorflow-1.0.1-cp35-cp35m-win_amd64.whl
tensorflow-1.0.1-cp35-cp35m-win_amd64.whl is not a supported wheel on this platform.


Edit: Ich hab hier was gefunden: https://github.com/tensorflow/tensorflow/issues/6999

Code: Alles auswählen

conda create --name tensorflow python=3.5
activate tensorflow
conda install jupyter
conda install scipy
pip install tensorflow
# or
# pip install tensorflow-gpu
Ich probier das mal aus.

Edit2: Geht auch nicht. :(

Code: Alles auswählen

C:\Anaconda\Scripts>conda.exe create --name tensorflow python=3.5
Fetching package metadata ...........
Solving package specifications: .

Package plan for installation in environment C:\Anaconda\envs\tensorflow:

The following NEW packages will be INSTALLED:

    pip:            9.0.1-py35_1
    python:         3.5.3-0
    setuptools:     27.2.0-py35_1
    vs2015_runtime: 14.0.25123-0
    wheel:          0.29.0-py35_0

Proceed ([y]/n)? y

python-3.5.3-0 100% |###############################| Time: 0:00:02  10.94 MB/s
setuptools-27. 100% |###############################| Time: 0:00:00  11.75 MB/s
wheel-0.29.0-p 100% |###############################| Time: 0:00:00  10.17 MB/s
pip-9.0.1-py35 100% |###############################| Time: 0:00:00  12.00 MB/s
#
# To activate this environment, use:
# > activate tensorflow
#
# To deactivate this environment, use:
# > deactivate tensorflow
#
# * for power-users using bash, you must source
#


C:\Anaconda\Scripts>activate tensorflow

(tensorflow) C:\Anaconda\Scripts>conda install jupyter
Fetching package metadata ...........
Solving package specifications: .

Package plan for installation in environment C:\Anaconda\envs\tensorflow:

The following NEW packages will be INSTALLED:

    bleach:              1.5.0-py35_0
    colorama:            0.3.7-py35_0
    decorator:           4.0.11-py35_0
    entrypoints:         0.2.2-py35_1
    html5lib:            0.999-py35_0
    icu:                 57.1-vc14_0   [vc14]
    ipykernel:           4.5.2-py35_0
    ipython:             5.3.0-py35_0
    ipython_genutils:    0.1.0-py35_0
    ipywidgets:          6.0.0-py35_0
    jinja2:              2.9.5-py35_0
    jpeg:                9b-vc14_0     [vc14]
    jsonschema:          2.5.1-py35_0
    jupyter:             1.0.0-py35_3
    jupyter_client:      5.0.0-py35_0
    jupyter_console:     5.1.0-py35_0
    jupyter_core:        4.3.0-py35_0
    libpng:              1.6.27-vc14_0 [vc14]
    markupsafe:          0.23-py35_2
    mistune:             0.7.4-py35_0
    nbconvert:           5.1.1-py35_0
    nbformat:            4.3.0-py35_0
    notebook:            4.4.1-py35_0
    openssl:             1.0.2k-vc14_0 [vc14]
    pandocfilters:       1.4.1-py35_0
    path.py:             10.1-py35_0
    pickleshare:         0.7.4-py35_0
    prompt_toolkit:      1.0.13-py35_0
    pygments:            2.2.0-py35_0
    pyqt:                5.6.0-py35_2
    python-dateutil:     2.6.0-py35_0
    pyzmq:               16.0.2-py35_0
    qt:                  5.6.2-vc14_3  [vc14]
    qtconsole:           4.2.1-py35_2
    simplegeneric:       0.8.1-py35_1
    sip:                 4.18-py35_0
    six:                 1.10.0-py35_0
    testpath:            0.3-py35_0
    tornado:             4.4.2-py35_0
    traitlets:           4.3.2-py35_0
    wcwidth:             0.1.7-py35_0
    widgetsnbextension:  2.0.0-py35_0
    win_unicode_console: 0.5-py35_0
    zlib:                1.2.8-vc14_3  [vc14]

Proceed ([y]/n)? y

colorama-0.3.7 100% |###############################| Time: 0:00:00 840.59 kB/s
decorator-4.0. 100% |###############################| Time: 0:00:00   1.91 MB/s
entrypoints-0. 100% |###############################| Time: 0:00:00   2.06 MB/s
ipython_genuti 100% |###############################| Time: 0:00:00   2.89 MB/s
jsonschema-2.5 100% |###############################| Time: 0:00:00   3.94 MB/s
markupsafe-0.2 100% |###############################| Time: 0:00:00   5.73 MB/s
mistune-0.7.4- 100% |###############################| Time: 0:00:00   7.19 MB/s
pandocfilters- 100% |###############################| Time: 0:00:00   3.01 MB/s
path.py-10.1-p 100% |###############################| Time: 0:00:00   7.67 MB/s
pygments-2.2.0 100% |###############################| Time: 0:00:00  12.01 MB/s
pyzmq-16.0.2-p 100% |###############################| Time: 0:00:00  11.80 MB/s
simplegeneric- 100% |###############################| Time: 0:00:00   1.65 MB/s
sip-4.18-py35_ 100% |###############################| Time: 0:00:00  10.88 MB/s
six-1.10.0-py3 100% |###############################| Time: 0:00:00   1.95 MB/s
testpath-0.3-p 100% |###############################| Time: 0:00:00   3.17 MB/s
tornado-4.4.2- 100% |###############################| Time: 0:00:00  11.77 MB/s
wcwidth-0.1.7- 100% |###############################| Time: 0:00:00   4.24 MB/s
win_unicode_co 100% |###############################| Time: 0:00:00   5.64 MB/s
html5lib-0.999 100% |###############################| Time: 0:00:00   7.54 MB/s
jinja2-2.9.5-p 100% |###############################| Time: 0:00:00  11.61 MB/s
pickleshare-0. 100% |###############################| Time: 0:00:00   1.91 MB/s
prompt_toolkit 100% |###############################| Time: 0:00:00  11.10 MB/s
python-dateuti 100% |###############################| Time: 0:00:00  10.82 MB/s
traitlets-4.3. 100% |###############################| Time: 0:00:00   9.51 MB/s
bleach-1.5.0-p 100% |###############################| Time: 0:00:00   4.06 MB/s
ipython-5.3.0- 100% |###############################| Time: 0:00:00  12.01 MB/s
jupyter_core-4 100% |###############################| Time: 0:00:00  10.10 MB/s
pyqt-5.6.0-py3 100% |###############################| Time: 0:00:00  10.53 MB/s
jupyter_client 100% |###############################| Time: 0:00:00  10.02 MB/s
nbformat-4.3.0 100% |###############################| Time: 0:00:00   9.03 MB/s
ipykernel-4.5. 100% |###############################| Time: 0:00:00   8.91 MB/s
nbconvert-5.1. 100% |###############################| Time: 0:00:00   8.34 MB/s
jupyter_consol 100% |###############################| Time: 0:00:00   9.03 MB/s
notebook-4.4.1 100% |###############################| Time: 0:00:00  10.33 MB/s
qtconsole-4.2. 100% |###############################| Time: 0:00:00   9.83 MB/s
widgetsnbexten 100% |###############################| Time: 0:00:00  10.74 MB/s
ipywidgets-6.0 100% |###############################| Time: 0:00:00   8.88 MB/s
jupyter-1.0.0- 100% |###############################| Time: 0:00:00 665.56 kB/s

(tensorflow) C:\Anaconda\Scripts>conda install scipy
Fetching package metadata ...........
Solving package specifications: .

Package plan for installation in environment C:\Anaconda\envs\tensorflow:

The following NEW packages will be INSTALLED:

    mkl:   2017.0.1-0
    numpy: 1.12.0-py35_0
    scipy: 0.19.0-np112py35_0

Proceed ([y]/n)? y

numpy-1.12.0-p 100% |###############################| Time: 0:00:00   7.52 MB/s
scipy-0.19.0-n 100% |###############################| Time: 0:00:01  10.58 MB/s

(tensorflow) C:\Anaconda\Scripts>pip install tensorflow
Collecting tensorflow
  Could not find a version that satisfies the requirement tensorflow (from versions: )
No matching distribution found for tensorflow
PeterOpa
User
Beiträge: 6
Registriert: Montag 31. Juli 2017, 20:44

Re: Installation von TensorFlow für Anaconda 4.3.1 64 auf Windows 10

Beitragvon PeterOpa » Montag 31. Juli 2017, 20:56

Seit ein paar Wochen habe ich Anaconda3 auf meinem W10 64 er Laptop installiert, und funktioniert mit Python 3.6 und und ohne Probleme.
Und tensorflow geht auch ... Und pytnon Notebooks ist phantastisch
Peter ...

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder