Abgesehen davon, dass das hier nix mit OOP zu tun hat:
- Verwende RawStrings bei Pfadangaben:
- der Name ``i`` ist kein guter Bezeichner! Wieso nicht ``file_name`` oder ``entry``?
- Der ganze Code ist Copy & Paste! Der schreit geradezu danach, durch eine Funktion allgemeiner zu werden:
Code: Alles auswählen
print "C:\\"
for i in os.listdir("C:\\"):
print i
print
#--- Ende Block 1
print "C:\\Users"
for i in os.listdir("C:\\Users"):
print i
print
#--- Ende Block 2
print "C:\\Windows"
for i in os.listdir("C:\\Windows"):
print i
# Ende Block 3
Schau Dir mal die Blöcke an und überlege, worin sie sich unterscheiden! Dann entwirf eine Funktion, die diese Funktionalität kapselt und rufe diese entsprechend mit den richtigen Parametern drei mal auf.
Danach können wir das dann noch weiter refactorn, indem das dreimalige Aufrufen der Funktion im Code vermieden wird und die Parameter in eine passende Datenstruktur ausgelagert werden.