Seite 1 von 1

(gelöst)ImportError?!

Verfasst: Montag 18. August 2008, 16:23
von Schaf220
Hi Leute,
ich hab ein kleines Problem und zwar wir mit immer ein ImportError angezeigt:
"ImportError: cannot import name OptionParser"
Ich denke das ich das Modul vieleicht nicht habe aber kann man das jetzt nach installieren? Wenn ja in welches Verzeichnis und wo bekomme ich es her?(Ich habe Version 2.5.1)

Hier mal der Code:

Code: Alles auswählen

from optparse import OptionParser 

parser = OptionParser()
parser.add_option("-o", "--operation", dest="operation")
(optionen, args) = parser.parse_args()

Gruß Schaf220

Verfasst: Montag 18. August 2008, 16:38
von Zap
Hast du dein Skript zufällig optparse.py genannt ?
Wenn ja hat es sich dann selbst importiert und nicht das Built-In Module von Python..

Verfasst: Montag 18. August 2008, 17:43
von Schaf220
Jo danke das war der Fehler jetzt gehts Vielen Dank!