Die Suche ergab 50 Treffer

von zarathustra
Dienstag 4. Juni 2019, 06:06
Forum: Installation/Konfigurieren
Thema: Package xlwings lässt sich nicht installieren
Antworten: 13
Zugriffe: 163

Re: Package xlwings lässt sich nicht installieren

Dabei bleibt es nicht. Den C++ compiler habe ich sogar drauf. Beim Build von pycairo kommt die Meldung, dass pycairo.h fehlt. Vermutlich muß man das komplette GTK installieren damit die Header zur Verfügung stehen. Wie gesagt, ich nehme wxPython. Das funktioniert. Und für GUI-Layout gibt es den wxFo...
von zarathustra
Montag 3. Juni 2019, 18:41
Forum: Installation/Konfigurieren
Thema: Package xlwings lässt sich nicht installieren
Antworten: 13
Zugriffe: 163

Re: Package xlwings lässt sich nicht installieren

Ähm jetzt steh' ich etwas auf dem Schlauch. Ich meine keine Fehlermeldung zu haben die auf einen fehlenden C++ Compiler verweist. Bzw. was soll der C++ Compiler bringen?
von zarathustra
Montag 3. Juni 2019, 06:42
Forum: Installation/Konfigurieren
Thema: Package xlwings lässt sich nicht installieren
Antworten: 13
Zugriffe: 163

Re: Package xlwings lässt sich nicht installieren

Das "win32" hat mich auch irritiert. Deshalb habe ich nachgesehen. Ist ein 64-bit Windows. Ich denke es liegt an der MINGW-Umgebung. Das Python wie auch die Module die man von da bekommt sind mit gcc compiliert und das xlwings bzw. pywin32 mit MSC. Deshalb geht das nicht beieinander denke ich. Auf d...
von zarathustra
Freitag 31. Mai 2019, 10:04
Forum: Installation/Konfigurieren
Thema: Package xlwings lässt sich nicht installieren
Antworten: 13
Zugriffe: 163

Re: Package xlwings lässt sich nicht installieren

Bei mir:

sys.version
'3.7.3 (default, May 28 2019, 08:37:07) [GCC 8.3.0 64 bit (AMD64)]'

sys.platform
'win32'

Bei meiner "Standartinstallation" werden mit pip install xlwings zwei DLL installiert.
"C:\Python3.7.3\xlwings64-0.15.8.dll" und "C:\Python3.7.3\xlwings32-0.15.8.dll"
von zarathustra
Freitag 31. Mai 2019, 08:45
Forum: Installation/Konfigurieren
Thema: Package xlwings lässt sich nicht installieren
Antworten: 13
Zugriffe: 163

Re: Package xlwings lässt sich nicht installieren

Die Fehlermeldung lautet:

ERROR: Could not find a version that satisfies the requirement pywin32>=224 (from xlwings) (from versions: none)
ERROR: No matching distribution found for pywin32>=224 (from xlwings)


Comtypes sind installiert
von zarathustra
Freitag 31. Mai 2019, 07:45
Forum: Installation/Konfigurieren
Thema: Package xlwings lässt sich nicht installieren
Antworten: 13
Zugriffe: 163

Package xlwings lässt sich nicht installieren

Guten Morgen, ich war gestern dabei mal GTK-GUI unter Windows 10 auszuprobieren. Die, wie hier: https://pygobject.readthedocs.io/en/latest/getting_started.html beschriebene Installation ließ sich auch problemlos durchführen und ein Python-GTK-Fenster erzeugen und starten. Jetzt wollte ich die sonsti...
von zarathustra
Montag 27. Mai 2019, 20:49
Forum: Wissenschaftliches Rechnen
Thema: Abstand zwischen Markern in matplotlib anpassen
Antworten: 5
Zugriffe: 90

Re: Abstand zwischen Markern in matplotlib anpassen

plt.step(i,i) ist keine gute Treppe?
von zarathustra
Montag 27. Mai 2019, 18:13
Forum: Wissenschaftliches Rechnen
Thema: Gnumerics Python Interpreter
Antworten: 15
Zugriffe: 186

Re: Gnumerics Python Interpreter

Schade. Ich dachte man könnte Python -mit Gtk als GUI-Toolkit und seinen sonstigen Modulen- als "Makroprogrammiersprache" für Gnumerics verwenden. So halt wie VBA in Excel, nur eben besser als VBA...
von zarathustra
Sonntag 26. Mai 2019, 21:29
Forum: Wissenschaftliches Rechnen
Thema: Gnumerics Python Interpreter
Antworten: 15
Zugriffe: 186

Re: Gnumerics Python Interpreter

Irgendwie scheint die Programmierschnittstelle nicht so üppig dokumentiert zu sein. Und es scheint teilweise nicht "sauber" zu funktionieren. Bei meinen Funktionstests, das Addieren zweier Zahlen, funktionierte zunächst nur mit Semikolon als Trenner zwischen den Zahlen. Zwischendurch aber auch mit K...
von zarathustra
Sonntag 26. Mai 2019, 12:59
Forum: Wissenschaftliches Rechnen
Thema: Gnumerics Python Interpreter
Antworten: 15
Zugriffe: 186

Re: Gnumerics Python Interpreter

Ein par Fragen habe ich doch noch bzw. wieder. Habe jetzt auf Linux das hier: https://help.gnome.org/users/gnumeric/s ... on.html.en und hier dann Kapitel 18.3.4 ausprobiert. Das funktionierte auf Anhieb, bis auf die Sache mit der Funktionsbeschreibung, die in der GUI-Liste der Funktionen erscheinen...
von zarathustra
Sonntag 26. Mai 2019, 09:36
Forum: Wissenschaftliches Rechnen
Thema: Gnumerics Python Interpreter
Antworten: 15
Zugriffe: 186

Re: Gnumerics Python Interpreter

Hab' ja diverse Linux unter Parallels am Start, daran liegt es nicht. Mit Debian und Cinnamon-Desktop funzt es ja. Ich habe da noch die Fehlermeldungen im Terminal die beim Start von gnumerics (mit gnumerics am Terminal) kommen, bzw. nach einigen Sekunden wenn das Plotfenster offen ist bzw. nach dem...
von zarathustra
Samstag 25. Mai 2019, 20:38
Forum: Wissenschaftliches Rechnen
Thema: Gnumerics Python Interpreter
Antworten: 15
Zugriffe: 186

Re: Gnumerics Python Interpreter

Hhmm ob GTK um Längen besser ist weiß ich nicht.

Gerade habe ich via pip3 install pycairo und pip3 install PyGObject installiert und ein Testfenster erzeugt. GTK braucht XQuartz,
wxPython nicht. Unter XQuartz sieht es etwas verwaschener aus. Auch das Gnumeric.
von zarathustra
Samstag 25. Mai 2019, 12:34
Forum: Wissenschaftliches Rechnen
Thema: Gnumerics Python Interpreter
Antworten: 15
Zugriffe: 186

Re: Gnumerics Python Interpreter

Der Pfad zum Interpreter ist: /opt/local/Library/Frameworks/Python.framework/Versions/2.7/bin Zumindest konnte ich mit der dortigen Python-Datei Python 2.7.16 (welches dem von Gnumeric entspricht) im Mac-Terminal starten. Mein Mac enthält auch noch eine 2.7.10 Installation (das ist, meine ich, die M...
von zarathustra
Samstag 25. Mai 2019, 08:43
Forum: Wissenschaftliches Rechnen
Thema: Gnumerics Python Interpreter
Antworten: 15
Zugriffe: 186

Re: Gnumerics Python Interpreter

Hallo __deets__, danke für die Info's. Auf meinem Debian Cinnamon ist es tatsächlich so, dass der Gnumeric-Python-Interpreter dem System-Python entspricht. Man braucht hier auch kein wxPython, GTK (import gi) ist vorhanden und man kann das benutzen. Für GUI-Entwicklung nimmt man dann vermutlich glad...
von zarathustra
Freitag 24. Mai 2019, 20:51
Forum: Wissenschaftliches Rechnen
Thema: Gnumerics Python Interpreter
Antworten: 15
Zugriffe: 186

Gnumerics Python Interpreter

Guten Abend, ich habe mal einige Fragen zu Gnumerics mit Python. Ich bin auf Linux und mit Macports auch auf Mojave. Ich möchte den Installationspfad des Gnumerics-Python-Interpreters ermitteln, damit ich ich gezielt mit dessen pip dort numpy, matplotlib, wxPython etc. installieren kann. Ich habe fe...